|MAC_TEST(4)||Device Drivers Manual||MAC_TEST(4)|
MAC framework testing policy
SYNOPSIS¶To compile the testing policy into your kernel, place the following lines in your kernel configuration file:
Alternately, to load the testing module at boot time, place the following line in your kernel configuration file:
and in loader.conf(5):
mac_testpolicy module implements a testing facility for the MAC framework. Among other things,
mac_testwill try to catch corrupt labels the system is attempting to destroy and drop to the debugger. Additionally, a set of statistics regarding the number of times various MAC framework entry points have been called is stored in the security.mac.test sysctl(8) tree.
Label Format¶No labels are defined for
SEE ALSO¶mac(4), mac_biba(4), mac_bsdextended(4), mac_ifoff(4), mac_lomac(4), mac_mls(4), mac_none(4), mac_partition(4), mac_portacl(4), mac_seeotheruids(4), mac(9)
mac_testpolicy module first appeared in FreeBSD 5.0 and was developed by the TrustedBSD Project.
AUTHORS¶This software was contributed to the FreeBSD Project by Network Associates Labs, the Security Research Division of Network Associates Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
BUGS¶While the MAC Framework design is intended to support the containment of the root user, not all attack channels are currently protected by entry point checks. As such, MAC Framework policies should not be relied on, in isolation, to protect against a malicious privileged user.
|July 25, 2015||Linux 4.9.0-9-amd64|