|NVD(4)||Device Drivers Manual||NVD(4)|
SYNOPSIS¶To compile this driver into your kernel, place the following lines in your kernel configuration file:
Or, to load the driver as a module at boot, place the following lines in loader.conf(5):
nvddriver exposes NVM Express (NVMe) namespaces as disks to the kernel disk storage API. It depends on the nvme(4) driver for notification of existing NVMe namespaces and submission of NVM I/O commands.
Device nodes from the
nvd driver will have
the format /dev/nvdX and are GEOM(4) disks which can be
partitioned by geom(8). Note that device nodes from the
nvme(4) driver are not GEOM(4) disks and
cannot be partitioned.
nvddriver defines a system-wide maximum delete size for NVMe devices. The default is 1GB. To select a different value, set the following tunable in loader.conf(5):
hw.nvd.delete_max=<delete size in bytes>
SEE ALSO¶GEOM(4), nvme(4), geom(8), nvmecontrol(8), disk(9)
nvddriver first appeared in FreeBSD 9.2.
nvddriver was developed by Intel and originally written by Jim Harris <jimharris@FreeBSD.org>, with contributions from Joe Golio at EMC.
This man page was written by Jim Harris <jimharris@FreeBSD.org>.
|January 28, 2016||Linux 4.19.0-10-amd64|