table of contents
|SND_MAESTRO3(4)||Device Drivers Manual||SND_MAESTRO3(4)|
NAME¶snd_maestro3 — ESS Maestro3/Allegro-1 bridge device driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device soundAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The snd_maestro3 driver provides support for the ESS Maestro3 and Allegro-1 sound chips under the PCM framework. These chips are mostly found in laptop computers and feature an AC97 mixer, a multi-channel sample rate converter that can mix up to four digital audio streams in hardware, recording support, and external volume control buttons. The firmware for the sound processor is licensed under the GNU Public License, and thus this driver is not included in the default GENERIC kernel.
HARDWARE¶The snd_maestro3 driver supports the following audio devices:
- ESS Technology Allegro-1
- ESS Technology Maestro3
DIAGNOSTICS¶The hardware volume control buttons can be connected to two different pin sets (GPIO or GD) on the chip, depending on the manufacturer. The driver has no way of determining this configuration, so a hint may be used to override the default guess. The default setting for hardware volume control assumes that GD pins are wired to control the hardware volume. For systems that have the GPIO pins wired to the hardware volume control buttons, add the line “
hint.pcm.0.hwvol_config="0"” to the file /boot/device.hints to override the default setting.
SEE ALSO¶sound(4), loader.conf(5)
HISTORY¶The snd_maestro3 driver first appeared in FreeBSD 4.3.
AUTHORS¶Scott Long ⟨scottl@FreeBSD.org⟩
Darrel Anderson ⟨email@example.com⟩
|December 15, 2005||Debian|