table of contents
|CAM(4)||Device Drivers Manual||CAM(4)|
NAME¶CAM — Common Access Method SCSI/ATA subsystem
DESCRIPTION¶The CAM subsystem provides a uniform and modular system for the implementation of drivers to control various SCSI and ATA devices, and to utilize different SCSI and ATA host adapters through host adapter drivers. When the system probes busses, it attaches any devices it finds to the appropriate drivers. The pass(4) driver, if it is configured in the kernel, will attach to all devices.
KERNEL CONFIGURATION¶There are a number of generic kernel configuration options for the CAM subsystem:
- This option enables the CAM debugging printf code. This will not actually cause any debugging information to be printed out when included by itself. Enabling printouts requires additional configuration. See below for details.
- This sets the maximum allowable number of concurrent "high power" commands. A "high power" command is a command that takes more electrical power than most to complete. An example of this is the SCSI START UNIT command. Starting a disk often takes significantly more electrical power than normal operation. This option allows the user to specify how many concurrent high power commands may be outstanding without overloading the power supply on his computer.
- This eliminates text descriptions of each SCSI Additional Sense Code and Additional Sense Code Qualifier pair. Since this is a fairly large text database, eliminating it reduces the size of the kernel somewhat. This is primarily necessary for boot floppies and other low disk space or low memory space environments. In most cases, though, this should be enabled, since it speeds the interpretation of SCSI error messages. Do not let the "kernel bloat" zealots get to you -- leave the sense descriptions in your kernel!
- This disables text descriptions of each SCSI opcode. This option, like the sense string option above, is primarily useful for environments like a boot floppy where kernel size is critical. Enabling this option for normal use is not recommended, since it slows debugging of SCSI problems.
- This is the SCSI "bus settle delay." In
CAM, it is specified in milliseconds,
not seconds like the old SCSI layer used to do. When the kernel boots, it
sends a bus reset to each SCSI bus to tell each device to reset itself to
a default set of transfer negotiations and other settings. Most SCSI
devices need some amount of time to recover from a bus reset. Newer disks
may need as little as 100ms, while old, slow devices may need much longer.
SCSI_DELAYis not specified, it defaults to 2 seconds. The minimum allowable value for
SCSI_DELAYis "100", or 100ms. One special case is that if the
SCSI_DELAYis set to 0, that will be taken to mean the "lowest possible value." In that case, the
SCSI_DELAYwill be reset to 100ms.
hint.da.0.at="scbus0" hint.da.0.target="0" hint.da.0.unit="0"
ADAPTERS¶The system allows common device drivers to work through many different types of adapters. The adapters take requests from the upper layers and do all IO between the SCSI or ATA bus and the system. The maximum size of a transfer is governed by the adapter. Most adapters can transfer 64KB in a single operation, however many can transfer larger amounts.
TARGET MODE¶Some adapters support target mode in which the system is capable of operating as a device, responding to operations initiated by another system. Target mode is supported for some adapters, but is not yet complete for this version of the CAM SCSI subsystem.
FILES¶see other CAM device entries.
DIAGNOSTICS¶When the kernel is compiled with options CAMDEBUG, an XPT_DEBUG CCB can be used to enable various amounts of tracing information on any specific device. Devices not being traced will not produce trace information. There are currently four debugging flags that may be turned on:
- This debugging flag enables general informational printfs for the device or devices in question.
- This debugging flag enables function-level command flow tracing. i.e. kernel printfs will happen at the entrance and exit of various functions.
- This debugging flag enables debugging output internal to various functions.
- This debugging flag will cause the kernel to print out all SCSI commands sent to a particular device or devices.
CAM_DEBUG_SUBTRACEwill produce kernel printfs in EXTREME numbers, and because of that, they are not especially useful. There are not many things logged at the
CAM_DEBUG_INFOlevel, so it is not especially useful. The most useful debugging flag is the
CAM_DEBUG_CDBflag. Users can enable debugging from their kernel config file, by using the following kernel config options:
- This enables CAM debugging. Without this option, users will not even be able to turn on debugging from userland via camcontrol(8).
- This allows the user to set the various debugging flags described above in a kernel config file. Flags may be ORed together if the user wishes to see printfs for multiple debugging levels.
- Specify a bus to debug. To debug all busses, set this to -1.
- Specify a target to debug. To debug all targets, set this to -1.
- Specify a lun to debug. To debug all luns, set this to -1.
CAMDEBUGoption is their config file, by using the camcontrol(8) utility. See camcontrol(8) for details.
SEE ALSO¶ada(4), aha(4), ahb(4), ahc(4), ahci(4), ata(4), bt(4), cd(4), ch(4), da(4), pass(4), pt(4), sa(4), xpt(4), camcontrol(8)
HISTORY¶The CAM SCSI subsystem first appeared in FreeBSD 3.0. The CAM ATA support was added in FreeBSD 8.0.
AUTHORS¶The CAM SCSI subsystem was written by Justin Gibbs and Kenneth Merry. The CAM ATA support was added by Alexander Motin ⟨mav@FreeBSD.org⟩.
|March 4, 2010||Debian|