table of contents
|AXE(4)||Device Drivers Manual||AXE(4)|
NAME¶axe — ASIX Electronics AX88172/178/772 USB Ethernet driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device ehciAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The axe driver provides support for USB Ethernet adapters based on the ASIX Electronics AX88172, AX88178 and AX88772 USB 2.0 chipsets. The AX88172 and AX88178 are USB 2.0 devices that contain a 10/100 Ethernet MAC with MII interface and are designed to work with both Ethernet and HomePNA transceivers. The AX88772 will additionally support 10/100/1000 MACs. These devices will operate with both USB 1.x and USB 2.0 controllers, however performance with 1.x controllers will be limited since the USB 1.x standard specifies a maximum transfer speed of 12Mbps. Users with USB 1.x controllers should therefore not expect to actually achieve 100Mbps speeds with these devices. All chipsets support a 64-bit multicast hash table, single perfect filter entry for the station address, all-multicast mode and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints. The axe driver supports the following media types:
- Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the /etc/rc.conf file.
- Set 10Mbps operation. The mediaopt option can also be used to enable full-duplex operation. Not specifying full-duplex implies half-duplex mode.
- Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to enable full-duplex operation. Not specifying full-duplex implies half-duplex mode.
- Force full duplex operation. The interface will operate in half duplex mode if this media option is not specified.
HARDWARE¶The axe driver supports ASIX Electronics AX88172/AX88178/AX88772 based USB Ethernet adapters including: AX88172:
- AboCom UF200
- Acer Communications EP1427X2
- ATen UC210T
- Billionton SnapPort
- Billionton USB2AR
- Buffalo (Melco Inc.) LUA-U2-KTX
- Corega USB2_TX
- D-Link DUBE100
- Goodway GWUSB2E
- JVC MP_PRX1
- LinkSys USB200M
- Netgear FA120
- Sitecom LN-029
- System TALKS Inc. SGC-X2UL
- Belkin F5D5055
- Logitec LAN-GTJ/U2A
- Buffalo (Melco Inc.) LUA3-U2-AGT
- Planex Communications GU1000T
- Sitecom Europe LN-028
- Buffalo (Melco Inc.) LUA3-U2-ATX
- Cisco-Linksys USB200Mv2
- D-Link DUBE100B1
- Planex UE-200TX-G
- Planex UE-200TX-G2
- axe%d: watchdog timeout
- A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired.
- axe%d: no memory for rx list
- The driver failed to allocate an mbuf for the receiver ring.
SEE ALSO¶altq(4), arp(4), miibus(4), netintro(4), ng_ether(4), rgephy(4), ifconfig(8) ASIX AX88172 AX88178 and AX88772 data sheets, http://www.asix.com.tw.
HISTORY¶The axe device driver first appeared in FreeBSD 5.0.
AUTHORS¶The axe driver was written by Bill Paul ⟨firstname.lastname@example.org⟩.
|January 16, 2011||Debian|