table of contents
|UNR(9)||Kernel Developer's Manual||UNR(9)|
— kernel unit number allocator
struct unrhdr *
low, int high,
struct mtx *mutex);
unrhdr *uh, u_int
unrhdr *uh, u_int
The kernel unit number allocator is a generic facility, which allows to allocate unit numbers within a specified range.
new_unrhdr(low, high, mutex)
- Initialize a new unit number allocator entity. The
low and high arguments specify
minimum and maximum number of unit numbers. There is no cost associated
with the range of unit numbers, so unless the resource really is finite,
INT_MAXcan be used. If mutex is not
NULL, it is used for locking when allocating and freeing units. Otherwise, internal mutex is used.
- Clear all units from the specified unit number allocator entity. This
function resets the entity as if it were just initialized with
- Delete specified unit number allocator entity. This function frees the
memory associated with the entity, it does not free any units. To free all
- Return a new unit number. The lowest free number is always allocated. This
function does not allocate memory and never sleeps, however it may block
on a mutex. If no free unit numbers are left,
- Same as
alloc_unr() except that mutex is assumed to be already locked and thus is not used.
- Allocate a specific unit number. This function allocates memory and thus
may sleep. The allocated unit number is returned on success. If the
specified number is already allocated or out of the range,
- Free a previously allocated unit number. This function may require allocating memory, and thus it can sleep. There is no pre-locked variant.
The above functions are implemented in sys/kern/subr_unit.c.
Kernel unit number allocator first appeared in FreeBSD 6.0.
Kernel unit number allocator was written by Poul-Henning Kamp. This manpage was written by Gleb Smirnoff.
|October 4, 2017||Debian|