|NG_DEVICE(4)||Device Drivers Manual||NG_DEVICE(4)|
devicenode is both a netgraph node and a system device interface. When a
devicenode is created, a new device entry appears which is accessible via the regular file operators such as open(2), close(2), read(2), write(2), etc.
The first node is created as /dev/ngd0, all subsequent nodes /dev/ngd1, /dev/ngd2, etc.
devicenode has a single hook with an arbitrary name. All data coming in over the hook will be presented to the device for read(2). All data coming in from the device entry by write(2) will be forwarded to the hook.
devicenode supports one non-generic control message:
- Returns device name corresponding to a node.
SHUTDOWN¶This node shuts down upon receipt of a
NGM_SHUTDOWNcontrol message, or upon hook disconnection. The associated device entry is removed and becomes available for use by future
SEE ALSO¶netgraph(4), ngctl(8)
devicenode type was first implemented in FreeBSD 5.0.
AUTHORS¶Mark Santcroos <email@example.com>
Gleb Smirnoff <glebius@FreeBSD.org>
|October 19, 2004||Linux 4.9.0-9-amd64|