|SGE(4)||Device Drivers Manual||SGE(4)|
Silicon Integrated Systems SiS190/191 Fast/Gigabit Ethernet driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
sgedevice driver provides support for SiS190 Fast Ethernet controllers and SiS191 Fast/Gigabit Ethernet controllers. All LOMs supported by the
sgedriver have TCP/UDP/IP checksum offload for transmit and receive, TCP segmentation offload (TSO), hardware VLAN tag stripping/insertion features. Due to lack of documentation Wake On Lan (WOL), Jumbo frame and an interrupt moderation mechanism are not supported yet. The
sgedriver supports the following media types:
- Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to rc.conf(5).
- Set 10Mbps operation.
- Set 100Mbps (Fast Ethernet) operation.
- Set 1000baseTX operation over twisted pair.
sgedriver supports the following media options:
- Force full duplex operation.
- Force half duplex operation.
sgedevice driver provides support for the following Ethernet controllers:
- SiS190 Fast Ethernet controller
- SiS191 Fast/Gigabit Ethernet controller
SEE ALSO¶altq(4), arp(4), miibus(4), netintro(4), ng_ether(4), rgephy(4), vlan(4), ifconfig(8)
sgedriver was written by
Alexander Pohoyda ⟨email@example.com⟩. And enhanced by
Nikolay Denev ⟨firstname.lastname@example.org⟩. It first appeared in FreeBSD 8.1.
|January 16, 2011||Debian|