|MAC_STUB(4)||Device Drivers Manual||MAC_STUB(4)|
MAC policy stub module
SYNOPSIS¶To compile the stub policy into your kernel, place the following lines in your kernel configuration file:
Alternately, to load the stub module at boot time, place the following line in your kernel configuration file:
and in loader.conf(5):
mac_stubpolicy module implements a stub MAC policy that has no effect on access control in the system. Unlike mac_none(4), each MAC entry point is defined as a “no-op”, so the policy module will be entered for each event, but no change in system behavior should result.
Label Format¶No labels are defined for
SEE ALSO¶mac(4), mac_biba(4), mac_bsdextended(4), mac_ifoff(4), mac_lomac(4), mac_mls(4), mac_none(4), mac_partition(4), mac_portacl(4), mac_seeotheruids(4), mac_test(4), mac(9)
mac_stubpolicy module first appeared in FreeBSD 5.1 and was developed by the TrustedBSD Project.
AUTHORS¶This software was contributed to the FreeBSD Project by Network Associates Labs, the Security Research Division of Network Associates Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
BUGS¶See mac(9) concerning appropriateness for production use. The TrustedBSD MAC Framework is considered experimental in FreeBSD. While the MAC Framework design is intended to support the containment of the root user, not all attack channels are currently protected by entry point checks. As such, MAC Framework policies should not be relied on, in isolation, to protect against a malicious privileged user.
|December 1, 2002||Debian|