table of contents
|AN(4)||Device Drivers Manual||AN(4)|
Aironet Communications 4500/4800 wireless network adapter driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
andriver provides support for Aironet Communications 4500 and 4800 wireless network adapters and variants, including the following:
- Aironet Communications 4500 and 4800 series
- Cisco Aironet 340 and 350 series
- Xircom Wireless Ethernet Adapter
andriver has Plug and Play support and will work in either configuration, however when using a hard-wired I/O address and IRQ, the driver configuration and the NIC's switch settings must agree. PCI cards require no switch settings of any kind and will be automatically probed and attached. All host/device interaction with the Aironet cards is via programmed I/O. The Aironet devices support 802.11 and 802.3 frames, power management, BSS (infrastructure) and IBSS (ad-hoc) operation modes. The
andriver encapsulates all IP and ARP traffic as 802.11 frames, however it can receive either 802.11 or 802.3 frames. Transmit speed is selectable between 1Mbps, 2Mbps, 5.5Mbps, 11Mbps or "auto" (the NIC automatically chooses the best speed). By default, the
andriver configures the Aironet card for infrastructure operation. For more information on configuring this device, see ifconfig(8).
- an%d: init failed
- The Aironet card failed to become ready after an initialization command was issued.
- an%d: failed to allocate %d bytes on NIC
- The driver was unable to allocate memory for transmit frames in the NIC's on-board RAM.
- an%d: device timeout
- The Aironet card failed to generate an interrupt to acknowledge a transmit command.
SEE ALSO¶altq(4), arp(4), miibus(4), netintro(4), wlan(4), ancontrol(8), ifconfig(8)
andevice driver first appeared in FreeBSD 4.0.
andriver was written by Bill Paul ⟨firstname.lastname@example.org⟩.
|July 16, 2005||Debian|