|ZFS-JAIL(8)||System Manager's Manual||ZFS-JAIL(8)|
Attaches and detaches ZFS filesystems from FreeBSD jails.
A ZFS dataset can be attached to a jail by using the
subcommand. You cannot attach a dataset to one jail and the children of the
same dataset to another jail. You can also not attach the root file system
of the jail or any dataset which needs to be mounted before the zfs rc
script is run inside the jail, as it would be attached unmounted until it is
mounted from the rc script inside the jail. To allow management of the
dataset from within a jail, the jailed property has to be
set and the jail needs access to the /dev/zfs
property cannot be changed from within a jail. See jail(8)
for information on how to allow mounting ZFS datasets from within a
A ZFS dataset can be detached from a jail
using the "
After a dataset is attached to a jail and the jailed property is set, a jailed file system cannot be mounted outside the jail, since the jail administrator might have set the mount point to an unacceptable value.
Attaches the specified filesystem to the jail identified by JID jailid. From now on this file system tree can be managed from within a jail if the jailed property has been set. To use this functuinality, the jail needs the allow.mount and allow.mount.zfs parameters set to 1 and the enforce_statfs parameter set to a value lower than 2.
See jail(8) for more information on managing jails and configuring the parameters above.
Detaches the specified filesystem from the jail identified by JID jailid.
|December 9, 2019||FreeBSD|