table of contents
|WPI(4)||Device Drivers Manual||WPI(4)|
NAME¶wpi — Intel 3945ABG Wireless LAN IEEE 802.11 driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device wpiAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The wpi driver provides support for the Intel 3945ABG Wireless network adapter wpi supports station, adhoc, and monitor mode operation. Only one virtual interface may be configured at any time. For more information on configuring this device, see ifconfig(8). This driver requires the firmware built with the wpifw module to work.
- wpi firmware license
EXAMPLES¶Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan0 create wlandev wpi0 inet 192.168.0.20 \ netmask 0xffffff00
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan0 create wlandev wpi0 ssid my_net up
ifconfig wlan0 create wlandev wpi0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
ifconfig wlan0 create wlandev wpi0 wlanmode adhoc ssid my_net \ wepmode on wepkey 0x01020304050607080910111213 weptxkey 1
- wpi%d: could not load firmware image '%s'
- The driver failed to load the firmware image using the firmware(9) subsystem. Verify the wpifw firmware module is installed.
- wpi%d: fatal firmware error
- An unknown error has occurred in the uploaded firmware, you may have to unload/reload the driver to continue.
- wpi%d: Radio transmitter is switched off
- The hardware switch controlling the radio is currently turned off. Data transmission is not possible in this state.
BUGS¶Not all the error messages are documented here. Background scanning is not currently supported.
SEE ALSO¶wpifw(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8).
AUTHORS¶The original wpi driver was written for OpenBSD by Damien Bergamini ⟨email@example.com⟩. Benjamin Close ⟨benjsc@FreeBSD.org⟩ ported wpi to FreeBSD.
|October 5, 2008||Debian|