|UFOMA(4)||Device Drivers Manual||UFOMA(4)|
NAME¶ufoma — USB mobile phone support
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device ufomaAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The ufoma driver provides support for USB mobile phone terminals in the subset of the Mobile Computing Promotion Consortium USB Implementation Guideline, which is adopted by FOMA, the NTT DoCoMo 3G system, terminal. These are partly like CDC ACM model based modems, which are supported by umodem(4), but the ufoma driver recognizes a specific USB descriptor that describes its role and interface structure, and it will negotiate its role when the device is open. They support a regular AT command set and the commands can either be multiplexed with the data stream or handled through separate pipes. In the latter case the AT commands have to be given on a device separate from the data device. The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
SYSCTLS¶These devices often have a few interface sets and these interfaces have their role, sometimes multiplexed. These roles are identified with the following sysctl MIBs:
- The modes which are supported by the interface.
- Current mode of the interface.
- Mode to transit when the device is open next.
- Accepts AT commands and go and pass packet communication data.
- Accepts AT commands but it does not pass data.
- Accepts OBEX frame which is used to exchange telephone book, etc.
- Vendor specific data may be passed.
- When an interface is recognized by the system but not used, the interface will be set to this mode.
- When an interface is not yet negotiated, the interface is in this mode.
HARDWARE¶Devices supported by the ufoma driver include:
- SHARP FOMA SH902i
- KYOCERA PHS AH-K3001V (a.k.a Kyopon)
- SANYO Vodafone3G V801SA
SEE ALSO¶Specification can be found at:
HISTORY¶The ufoma driver appeared in FreeBSD 7.0, partly derived from the umodem(4) code.
BUGS¶Interfaces with multiplexed commands and data and interfaces with commands only are supported.
|November 22, 2006||Debian|