|U3G(4)||Device Drivers Manual||U3G(4)|
NAME¶u3g — USB support for 3G datacards
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device u3gAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The u3g driver provides support for the multiple USB-to-serial interfaces exposed by many 3G USB/PCCard modems. The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
HARDWARE¶The u3g driver supports the following adapters:
- Option GT 3G Fusion, GT Fusion Quad, etc. (only 3G part, not WLAN)
- Option GT 3G, GT 3G Quad, etc.
- Vodafone Mobile Connect Card 3G
- Qualcomm Inc. CDMA MSM
- Huawei B190, E180v, E220 ('<Huawei Mobile>')
- Novatel U740, MC950D, X950D, etc.
- Sierra MC875U, MC8775U, etc.
SEE ALSO¶tty(4), ucom(4), usb(4), usb_quirk(4), usbconfig(5)
HISTORY¶The u3g driver appeared in FreeBSD 7.2, is based on the uark(4) driver, and written by Andrea Guzzo ⟨firstname.lastname@example.org⟩ in September 2008.
AUTHORS¶The u3g driver was written by Andrea Guzzo ⟨email@example.com⟩ and
Nick Hibma ⟨firstname.lastname@example.org⟩. Hardware for testing was provided by AnyWi Technologies, Leiden, NL.
|October 7, 2008||Debian|