|TDFX(4)||Device Drivers Manual||TDFX(4)|
NAME¶tdfx — Voodoo Graphics and VoodooII Memory Access GLIDE device driver
DESCRIPTION¶This driver creates an entry in /dev that allows programs (mostly GLIDE-based software) to access the device memory of the Voodoo Graphics and VoodooII 3D accelerators created by 3Dfx, Inc. This provides an interface for applications based on the GLIDE API or that simply use the API provided by the linux /dev/3dfx device to use the video device. Supports all cards based on the following chipsets:
- 3Dfx Voodoo Graphics
- 3Dfx Voodoo II
- Diamond Multimedia Monster 3D
- Diamond Multimedia Monster 3D II
- Symlinked to default 3dfx board
- Character Device programming interface
- Mirrors of above interfaces
- (Some apps use /dev/voodoo)
HISTORY¶The tdfx driver appeared in FreeBSD 5.0, and was originally developed for Linux kernel 2.0.x, later written for 2.2.x and 2.4.x.
AUTHORS¶The driver was developed by Coleman Kane ⟨email@example.com⟩ after the linux version of this driver by Darryll Straus, John Taylor, Jens Axboe, Carlo Wood ⟨firstname.lastname@example.org⟩ and Joseph Kain ⟨email@example.com⟩ to be directly compatible with it and support the many GLIDE based games available for Linux and UNIX.
|February 19, 2001||Debian|