|SND_UAUDIO(4)||Device Drivers Manual||SND_UAUDIO(4)|
NAME¶snd_uaudio — USB audio device driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device soundAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The snd_uaudio driver provides support for USB audio class devices. A USB audio device consists of a number of components: input terminals (e.g. USB digital input), output terminals (e.g. speakers), and a number of units in between (e.g. volume control). Refer to the ‘
USB Audio Class Specification’ for more information.
SEE ALSO¶sound(4), usb(4) USB Audio Class Specifications, http://www.usb.org/developers/devclass_docs/.
HISTORY¶The snd_uaudio driver first appeared in FreeBSD 4.7.
AUTHORS¶This manual page was adopted from NetBSD 1.6 and modified for FreeBSD by Hiten Pandya ⟨hmp@FreeBSD.org⟩.
BUGS¶The PCM framework in FreeBSD, as of this writing, does not handle device un-registrations in a properly abstracted manner, i.e., a detach request is refused by the PCM framework if the device is in use. For USB and supposedly other detach-able busses, it is necessary to allow the device un-registration to complete successfully, otherwise the driver leaves wild pointers to invalid data structures and thus leading to a panic.
|December 15, 2005||Debian|