|SND_ES137X(4)||Device Drivers Manual||SND_ES137X(4)|
NAME¶snd_es137x — Ensoniq AudioPCI ES137x bridge device driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device soundAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The snd_es137x bridge driver allows the generic audio driver sound(4) to attach to the Ensoniq 137x audio cards.
Runtime Configuration¶The following sysctl(8) variables are available in addition to those available to all sound(4) devices:
- Controls the PCI latency timer setting. Increasing this value will solve most popping and crackling issues (especially on VIA motherboards).
- Enables S/PDIF output on the primary playback channel. This sysctl(8) variable is available only if the device is known to support S/PDIF output.
- Experimental polling mode, where the driver operates by querying the device state on each tick using callout(9). Polling is disabled by default. Do not enable it unless you are facing weird interrupt problems or if the device cannot generate interrupts at all.
HARDWARE¶The snd_es137x driver supports the following sound cards:
- Creative CT5880-A
- Creative CT5880-C
- Creative CT5880-D
- Creative CT5880-E
- Creative SB AudioPCI CT4730
- Ensoniq AudioPCI ES1370
- Ensoniq AudioPCI ES1371-A
- Ensoniq AudioPCI ES1371-B
- Ensoniq AudioPCI ES1373-A
- Ensoniq AudioPCI ES1373-B
- Ensoniq AudioPCI ES1373-8
HISTORY¶The snd_es137x device driver first appeared in FreeBSD 4.0.
AUTHORS¶Russell Cattelan ⟨firstname.lastname@example.org⟩
Cameron Grant ⟨cg@FreeBSD.org⟩
Jonathan Noack ⟨email@example.com⟩
|November 29, 2006||Debian|