|SIIS(4)||Device Drivers Manual||SIIS(4)|
NAME¶siis — SiliconImage Serial ATA Host Controller driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device pciAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
- controls Message Signaled Interrupts (MSI) usage by the specified controller.
- controls SATA interface Power Management for the
specified channel, allowing some power to be saved at the cost of
additional command latency. Possible values:
- interface Power Management is disabled (default);
- device is allowed to initiate PM state change, host is passive.
- setting to nonzero value limits maximum SATA revision (speed). Values 1, 2 and 3 are respectively 1.5, 3 and 6Gbps.
DESCRIPTION¶This driver provides the CAM(4) subsystem with native access to the SATA ports of controller. Each SATA port is represented to CAM as a separate bus with 16 targets. Most of the bus-management details are handled by the SATA-specific transport of CAM. Connected ATA disks are handled by the ATA protocol disk peripheral driver ada(4). ATAPI devices are handled by the SCSI protocol peripheral drivers cd(4), da(4), sa(4), etc. Driver features include support for Serial ATA and ATAPI devices, Port Multipliers (including FIS-based switching), hardware command queues (31 command per port), Native Command Queuing, SATA interface Power Management, device hot-plug and Message Signaled Interrupts. Same hardware is also supported by the atasiliconimage driver from ata(4) subsystem. If both drivers are loaded at the same time, this one will be given precedence as the more functional of the two.
HARDWARE¶The siis driver supports the following controllers:
SEE ALSO¶ada(4), ata(4), cam(4), cd(4), da(4), sa(4)
HISTORY¶The siis driver first appeared in FreeBSD 8.0.
AUTHORS¶Alexander Motin ⟨mav@FreeBSD.org⟩.
|July 18, 2009||Debian|