|SPLASH(4)||Device Drivers Manual||SPLASH(4)|
NAME¶splash — splash screen / screen saver interface
DESCRIPTION¶The splash pseudo device driver adds support for the splash screen and screen savers to the kernel. This driver is required if the splash bitmap image is to be loaded or any screen saver is to be used.
Splash screen¶You can load and display an arbitrary bitmap image file as a welcome banner on the screen when the system is about to start. This image will remain on the screen during kernel initialization process until the login prompt appears on the screen or until a screen saver is loaded and initialized. The image will also disappear if you hit any key, although this may not work immediately if the kernel is still probing devices. If you specify the -c or -v boot option when loading the kernel, the splash image will not appear. However, it is still loaded and can be used as a screen saver later: see below. In order to display the bitmap, the bitmap file itself and the matching splash image decoder module must be loaded by the boot loader. Currently the following decoder modules are available:
- W*ndows BMP file decoder. While the BMP file format allows images of various color depths, this decoder currently only handles 256 color bitmaps. Bitmaps of other color depths will not be displayed.
- ZSoft PCX decoder. This decoder currently only supports version 5 8-bpp single-plane images.
Screen saver¶The screen saver will activate when the system is considered idle: i.e. when the user has not typed a key or moved the mouse for a specified period of time. As the screen saver is an optional module, it must be explicitly loaded into memory. Currently the following screen saver modules are available:
- This screen saver simply blanks the screen.
- Animated BSD Daemon screen saver.
- The screen will gradually fade away.
- A fire which becomes higher as load increases.
- The screen will be blanked, similar to blank_saver.ko. If the monitor and the video card's BIOS support it the screen will also be powered off.
- Animated graphical BSD Daemon.
- Draws a shower on the screen.
- Draws a snake of string.
- Twinkling stars.
- Streaking stars.
The timeout value in seconds can be specified as follows:
Alternatively, you can set the saver variable in the /etc/rc.conf to the screen saver of your choice and the timeout value to the blanktime variable so that the screen saver is automatically loaded and the timeout value is set when the system starts. The screen saver may be instantly activated by hitting the saver key: the defaults are Shift-Pause on the AT enhanced keyboard and Shift-Ctrl-NumLock/Pause on the AT 84 keyboard. You can change the saver key by modifying the keymap (see kbdcontrol(1), keymap(5)), and assign the saver function to a key of your preference. The screen saver will not run if the screen is not in text mode.
vidcontrol -t N
Splash screen as a screen saver¶If you load a splash image but do not load a screen saver, you can continue using the splash module as a screen saver. The screen blanking interval can be specified as described in the Screen saver section above.
- boot loader configuration defaults
- system configuration information
- splash image decoder modules
- screen saver modules
- the VESA support module
EXAMPLES¶In order to load the splash screen or the screen saver, you must have the following line in the kernel configuration file.
Next, edit /boot/loader.conf (see loader.conf(5)) and include the following lines:
splash_bmp_load="YES" bitmap_load="YES" bitmap_name="/boot/chuck.bmp"
splash_pcx_load="YES" vesa_load="YES" bitmap_load="YES" bitmap_name="/boot/chuck.pcx"
CAVEATS¶Both the splash screen and the screen saver work with syscons(4) only.
SEE ALSO¶vidcontrol(1), syscons(4), vga(4), loader.conf(5), rc.conf(5), kldload(8), kldunload(8)
HISTORY¶The splash driver first appeared in FreeBSD 3.1.
AUTHORS¶The splash driver and this manual page were written by Kazutaka Yokota ⟨yokota@FreeBSD.org⟩. The splash_bmp module was written by Michael Smith ⟨msmith@FreeBSD.org⟩ and Kazutaka Yokota. The splash_pcx module was written by Dag-Erling Smørgrav ⟨des@FreeBSD.org⟩ based on the splash_bmp code.
BUGS¶If you load a screen saver while another screen saver has already been loaded, the first screen saver will not be automatically unloaded and will remain in memory, wasting kernel memory space.
|November 29, 2010||Debian|