table of contents
|KUE(4)||Device Drivers Manual||KUE(4)|
NAME¶kue — Kawasaki LSI KL5KUSB101B USB Ethernet driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device uhciAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The kue driver provides support for USB Ethernet adapters based on the Kawasaki LSI KL5KLUSB101B chipset. The KL5KLUSB101B supports a 128-entry multicast filter, single perfect filter entry for the station address and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints. The Kawasaki chipset supports only 10Mbps half-duplex mode, hence there are no ifmedia(4) modes to select. For more information on configuring this device, see ifconfig(8).
HARDWARE¶The kue driver supports Kawasaki LSI KL5KLUSB101B based USB Ethernet adapters including:
- 3Com 3c19250
- 3Com 3c460 HomeConnect Ethernet USB Adapter
- ADS Technologies USB-10BT
- AOX USB101
- ATen UC10T
- Abocom URE 450
- Corega USB-T
- D-Link DSB-650C
- Entrega NET-USB-E45, NET-HUB-3U1E
- I/O Data USB ETT
- Kawasaki DU-H3E
- LinkSys USB10T
- Netgear EA101
- Peracom USB Ethernet Adapter
- Psion Gold Port USB Ethernet adapter
- SMC 2102USB, 2104USB
- kue%d: watchdog timeout
- A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired.
- kue%d: no memory for rx list
- The driver failed to allocate an mbuf for the receiver ring.
SEE ALSO¶arp(4), netintro(4), ng_ether(4), ifconfig(8)
HISTORY¶The kue device driver first appeared in FreeBSD 4.0.
AUTHORS¶The kue driver was written by Bill Paul ⟨email@example.com⟩.
BUGS¶The kue driver does not accumulate Ethernet collisions statistics because the Kawasaki firmware does not appear to maintain any internal statistics.
|October 7, 2006||Debian|