|GEM(4)||Device Drivers Manual||GEM(4)|
NAME¶gem — ERI/GEM/GMAC Ethernet device driver
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device miibusAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The gem driver provides support for the GMAC Ethernet hardware found mostly in the last Apple PowerBooks G3s and most G4-based Apple hardware, as well as Sun UltraSPARC machines. All controllers supported by the gem driver have TCP checksum offload capability for both receive and transmit, support for the reception and transmission of extended frames for vlan(4) and a 512-bit multicast hash filter.
HARDWARE¶Chips supported by the gem driver include:
- Apple GMAC
- Sun ERI 10/100 Mbps Ethernet
- Sun GEM Gigabit Ethernet
- Sun Gigabit Ethernet PCI 2.0/3.0 (GBE/P) (part no. 501-4373)
- Sun Gigabit Ethernet SBus 2.0/3.0 (GBE/S) (part no. 501-4375)
NOTES¶On sparc64 the gem driver respects the local-mac-address? system configuration variable which can be set in the Open Firmware boot monitor using the setenv command or by eeprom(8). If set to “
false” (the default), the gem driver will use the system's default MAC address for all of its devices. If set to “
true”, the unique MAC address of each interface is used if present rather than the system's default MAC address. Supported interfaces having their own MAC address include the on-board Sun ERI 10/100 Mbps on boards equipped with more than one Ethernet interface and the Sun Gigabit Ethernet 2.0/3.0 GBE add-on cards.
SEE ALSO¶altq(4), miibus(4), netintro(4), vlan(4), eeprom(8), ifconfig(8)
HISTORY¶The gem device driver appeared in NetBSD 1.6. The first FreeBSD version to include it was FreeBSD 5.0.
AUTHORS¶The gem driver was written for NetBSD by Eduardo Horvath ⟨eeh@NetBSD.org⟩. It was ported to FreeBSD by Thomas Moestl ⟨tmm@FreeBSD.org⟩ and later on improved by Marius Strobl ⟨marius@FreeBSD.org⟩. The man page was written by Thomas Klausner ⟨wiz@NetBSD.org⟩.
|December 25, 2009||Debian|