|FWE(4)||Device Drivers Manual||FWE(4)|
NAME¶fwe — Ethernet emulation driver for FireWire
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
device firewireAlternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTION¶The fwe driver provides non-standard Ethernet emulation over FireWire (IEEE 1394). firewire(4) and fwohci(4) must be configured in the kernel as well. This driver exploits asynchronous stream over IEEE 1394 to carry Ethernet frames. The stream channel can be specified by the hw.firewire.fwe.stream_ch sysctl(8). This driver supports polling(4) as well if it is compiled with the
SEE ALSO¶arp(4), firewire(4), fwip(4), fwohci(4), netintro(4), ng_ether(4), polling(4), ifconfig(8), kldload(8), sysctl(8)
HISTORY¶The fwe device driver first appeared in FreeBSD 5.0.
AUTHORS¶The fwe driver and this manual page were written by Hidetoshi Shimokawa.
BUGS¶This driver emulates Ethernet in a very adhoc way and it does not reserve a stream channel using an isochronous manager. Note that this driver uses a protocol which is very different from RFC 2734 (IPv4 over IEEE 1394).
|July 16, 2005||Debian|