Scroll to navigation

DEVTONAME(9) Kernel Developer's Manual DEVTONAME(9)

NAME

devtonameconverts dev_t data into a string indicating the device name

SYNOPSIS

#include <sys/param.h>
#include <sys/conf.h>
const char *
devtoname(dev_t dev);

DESCRIPTION

The devtoname() function returns a pointer to the name of the device passed to it. The name is whatever was set to it in make_dev(). If no name is associated with dev, a pointer to a string consisting of a “#” followed by “major/minor” as it applies to dev is returned.

HISTORY

The devtoname() interface first appeared in FreeBSD 4.0
September 25, 1999 Debian