|BKTR(4)||Device Drivers Manual||BKTR(4)|
NAME¶bktr — Brooktree Bt848/849/878/879 and Pinnacle PCTV video capture driver
DESCRIPTION¶The bktr driver provides support for PCI video capture and VBI capture on low cost, high performance boards. The driver is based on the Matrox Meteor driver and uses the same API. The bktr driver should support most video cards based on the Brooktree Bt848/849/878/879 Video Capture Chip. Also supported are most Pinnacle PCTV video cards. Furthermore, the driver supports FM Radio if the tuner supports it. The driver currently supports the following features:
PCI to PCI dma transfer clipping yuv rgb16 rgb24 rgb32
options BROOKTREE_SYSTEM_DEFAULT=BROOKTREE_PAL options BROOKTREE_SYSTEM_DEFAULT=BROOKTREE_NTSC
nnnn’ is set to an integer from 1 to 23 taken from the following table:
nnnn’ is set to an integer from 1 to 16 taken from the following table:
- 9 /* These have FM Radio support */
- 10 /* These have FM Radio support */
- 11 /* These have FM Radio support */
HARDWARE¶The bktr driver supports video capture cards based on the Brooktree Bt848/849/878/879 chips, as well as Pinnacle PCTV cards, including:
- AOpen VA1000
- AVerMedia AVerTV Studio
- AVerMedia TF/FM-98
- ATI TV Wonder VE
- Hauppauge WinCast/TV
- Hauppauge WinTV-Go-FM
- Hauppauge WinTV-pci
- Hauppauge WinTV-radio
- Intel Smart Video Recorder III
- KWORLD PCI TV Tuner
- Miro PC TV
- Pinnacle PCTV Pro
- Pinnacle PCTV Rave
- PixelView PlayTV PAK
- PixelView PlayTV Pro (rev 4C, 9D)
- SIGMA TV II
- STB TV PCI Television Tuner
- Super TV Tuner
- TerraTec TValue
- V-Stream XPERT TV-PVR 878
- Video Highway XTreme
- VideoLogic Captivator PCI
- Examples of what you can do with the (similarly designed) Meteor driver.
- A TV and Camera display program utilizing the bktr driver - requires that The X Window System and The Ports Collection also be installed.
- A program to capture and display Teletext (VideoText) pages - requires that The X Window System and The Ports Collection also be installed.
- An FM Radio Tuner for cards which have an FM Radio tuner fitted - requires that The X Window System and The Ports Collection also be installed. It also requires Motif or the lesstif port.
HISTORY¶The bktr driver first appeared in FreeBSD 2.2.
AUTHORS¶This driver is based on the work of Jim Lowe ⟨email@example.com⟩, Mark Tinguely ⟨firstname.lastname@example.org⟩, Amancio Hasty ⟨email@example.com⟩, Roger Hardiman ⟨roger@FreeBSD.org⟩ and a bunch of other people. Support for Pinnacle PCTV Rave cards was added by Branko Lankester ⟨firstname.lastname@example.org⟩.
|January 18, 2006||Debian|