table of contents
|VOP_VPTOCNP(9)||Kernel Developer's Manual||VOP_VPTOCNP(9)|
NAME¶VOP_VPTOCNP — translate a vnode to its component name
#include <sys/vnode.h> int
VOP_VPTOCNP(struct vnode *vp, struct vnode **dvp, char *buf, int *buflen);
DESCRIPTION¶This translates a vnode into its component name, and writes that name to the head of the buffer specified by buf
- The vnode to translate.
- The vnode of the parent directory of vp.
- The buffer into which to preprend the component name.
- The remaining size of the buffer.
LOCKS¶The vnode should be locked on entry and will still be locked on exit. The parent directory vnode will be unlocked on a successful exit. However, it will have its hold count incremented.
RETURN VALUES¶Zero is returned on success, otherwise an error code is returned.
- The buffer was not large enough to hold the vnode's component name.
- The vnode was not found on the file system.
SEE ALSO¶VOP_LOOKUP(9), vnode(9)
NOTES¶This interface is a work in progress.
HISTORY¶The function VOP_VPTOCNP appeared in FreeBSD 8.0.
AUTHORS¶This manual page was written by Joe Marcus Clarke.
|December 7, 2008||Debian|