table of contents
|EVENTHANDLER(9)||Kernel Developer's Manual||EVENTHANDLER(9)|
NAME¶EVENTHANDLER — kernel event handling functions
SYNOPSIS¶#include <sys/eventhandler.h> EVENTHANDLER_DECLARE(name, type); EVENTHANDLER_INVOKE(name, ...); eventhandler_tag
EVENTHANDLER_REGISTER(name, func, arg, priority); EVENTHANDLER_DEREGISTER(name, tag); eventhandler_tag
eventhandler_register(struct eventhandler_list *list, const char *name, void *func, void *arg, int priority); void
eventhandler_deregister(struct eventhandler_list *list, eventhandler_tag tag); struct eventhandler_list *
eventhandler_find_list(const char *name); void
eventhandler_prune_list(struct eventhandler_list *list);
DESCRIPTION¶The EVENTHANDLER mechanism provides a way for kernel subsystems to register interest in kernel events and have their callback functions invoked when these events occur. The normal way to use this subsystem is via the macro interface. The macros that can be used for working with event handlers and callback function lists are:
- This macro declares an event handler named by argument name with callback functions of type type.
- This macro registers a callback function
func with event handler name.
When invoked, function func will be invoked with
argument arg as its first parameter along with any
additional parameters passed in via macro
EVENTHANDLER_INVOKE() (see below). Callback functions
are invoked in order of priority. The relative priority of each callback
among other callbacks associated with an event is given by argument
priority, which is an integer ranging from
EVENTHANDLER_PRI_FIRST(highest priority), to
EVENTHANDLER_PRI_LAST(lowest priority). The symbol
EVENTHANDLER_PRI_ANYmay be used if the handler does not have a specific priority associated with it. If registration is successful, EVENTHANDLER_REGISTER() returns a cookie of type eventhandler_tag.
- This macro removes a previously registered callback associated with tag tag from the event handler named by argument name.
- This macro is used to invoke all the callbacks associated with event handler name. This macro is a variadic one. Additional arguments to the macro after the name parameter are passed as the second and subsequent arguments to each registered callback function.
- The eventhandler_register() function is
used to register a callback with a given event. The arguments expected by
this function are:
- A pointer to an existing event handler list, or
NULL. If list is
NULL, the event handler list corresponding to argument name is used.
- The name of the event handler list.
- A pointer to a callback function. Argument arg is passed to the callback function func as its first argument when it is invoked.
- The relative priority of this callback among all the
callbacks registered for this event. Valid values are those in the
- The eventhandler_deregister() function removes the callback associated with tag tag from the event handler list pointed to by list. This function is safe to call from inside an event handler callback.
- The eventhandler_find_list() function returns a pointer to event handler list structure corresponding to event name.
- The eventhandler_prune_list() function removes all deregistered callbacks from the event list list.
Kernel Event Handlers¶The following event handlers are present in the kernel:
- Callbacks invoked when the system is being sent to sleep.
- Callbacks invoked when the system is being woken up.
- Callbacks invoked when a new entry is created under /dev.
- Callbacks invoked when an address is set up on a network interface.
- Callbacks invoked when an interface is cloned.
- Callbacks invoked when a new network interface appears.
- Callbacks invoked when a network interface is taken down.
- Callbacks invoked when the power profile of the system changes.
- Callbacks invoked when a process performs an exec() operation.
- Callbacks invoked when a process exits.
- Callbacks invoked when a process forks a child.
- Callbacks invoked at shutdown time, before file systems are synchronized.
- Callbacks invoked at shutdown time, after all file systems are synchronized.
- Callbacks invoked just before halting the system.
- Callbacks invoked when virtual memory is low.
- Callbacks invoked when the system watchdog timer is reinitialized.
RETURN VALUES¶The macro EVENTHANDLER_REGISTER() and function eventhandler_register() return a cookie of type eventhandler_tag, which may be used in a subsequent call to EVENTHANDLER_DEREGISTER() or eventhandler_deregister(). The eventhandler_find_list() function returns a pointer to an event handler list corresponding to parameter name, or
NULLif no such list was found.
HISTORY¶The EVENTHANDLER facility first appeared in FreeBSD 4.0.
AUTHORS¶This manual page was written by Joseph Koshy ⟨jkoshy@FreeBSD.org⟩.
|January 7, 2005||Debian|