|XPT(4)||Device Drivers Manual||XPT(4)|
xpt — CAM
transport layer interface
xpt driver provides a way for userland
applications to issue certain CAM CCBs to the kernel.
xpt driver allows direct access
to the CAM subsystem, system administrators should exercise caution when
granting access to this driver. If used improperly, this driver can allow
userland applications to crash a machine or cause data loss.
There is no kernel configuration required for the
xpt driver. It is enabled when SCSI support is
enabled in the kernel. There is one instance of the xpt driver per CAM
transport layer instance. Since there is currently only one CAM transport
layer, there will only be one instance of this driver.
- This ioctl takes certain kinds of CAM CCBs and passes them through to the
CAM transport layer for action. Only the following CCB types are
The above CCBs are the only ones supported since it makes more sense to send them through a generic passthrough device rather than a passthrough device tied to a particular underlying SCSI device.
- This ioctl takes an XPT_GDEVLIST CCB, and returns the passthrough device corresponding to the device in question.
- Character device node for the
The CAM transport layer driver first appeared in FreeBSD 3.0.
Kenneth Merry <ken@FreeBSD.org>
|October 10, 1998||Debian|