|MAC_NONE(4)||Device Drivers Manual||MAC_NONE(4)|
mac_none — null
MAC policy module
To compile the null policy into your kernel, place the following lines in your kernel configuration file:
Alternately, to load the none module at boot time, place the following line in your kernel configuration file:
and in loader.conf(5):
mac_none policy module implements a
none MAC policy that has no effect on access control in the system. Unlike
mac_stub(4), none of the MAC entry points are defined.
No labels are defined for
mac_none policy module first appeared
in FreeBSD 5.0 and was developed by the TrustedBSD
This software was contributed to the FreeBSD Project by Network Associates Labs, the Security Research Division of Network Associates Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
While the MAC Framework design is intended to support the containment of the root user, not all attack channels are currently protected by entry point checks. As such, MAC Framework policies should not be relied on, in isolation, to protect against a malicious privileged user.
|July 25, 2015||Debian|