|CAS(4)||Device Drivers Manual||CAS(4)|
cas — Sun
Cassini/Cassini+ and National Semiconductor DP83065 Saturn Gigabit Ethernet
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
cas driver provides support for the
Sun Cassini/Cassini+ and National Semiconductor DP83065 Saturn Gigabit
Ethernet controllers found on-board in Sun UltraSPARC machines and as add-on
All controllers supported by the
driver have TCP/UDP checksum offload capability for both receive and
transmit, support for the reception and transmission of extended frames for
vlan(4) and an interrupt coalescing/moderation mechanism
as well as a 512-bit multicast hash filter.
cas driver also supports Jumbo Frames
(up to 9022 bytes), which can be configured via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the
ifconfig(8) utility configures the adapter to receive and
transmit Jumbo Frames.
The chips supported by the
- National Semiconductor DP83065 Saturn Gigabit Ethernet
- Sun Cassini Gigabit Ethernet
- Sun Cassini+ Gigabit Ethernet
The following add-on cards are known to work with the
cas driver at this time:
- Sun GigaSwift Ethernet 1.0 MMF (Cassini Kuheen) (part no. 501-5524)
- Sun GigaSwift Ethernet 1.0 UTP (Cassini) (part no. 501-5902)
- Sun GigaSwift Ethernet UTP (GCS) (part no. 501-6719)
- Sun Quad GigaSwift Ethernet UTP (QGE) (part no. 501-6522)
- Sun Quad GigaSwift Ethernet PCI-X (QGE-X) (part no. 501-6738)
On sparc64 the
cas driver respects the
local-mac-address? system configuration variable which
can be set in the Open Firmware boot monitor using the
setenv command or by eeprom(8). If
set to “
false” (the default), the
cas driver will use the system's default MAC address
for all of its devices. If set to
true”, the unique MAC address of each
interface is used if present rather than the system's default MAC
Supported interfaces having their own MAC address include on-board versions on boards equipped with more than one Ethernet interface and all add-on cards.
cas device driver appeared in
FreeBSD 8.0 and FreeBSD 7.3.
It is named after the
cas driver which first
appeared in OpenBSD 4.1 and supports the same set of
controllers but is otherwise unrelated.
|March 24, 2012||Debian|