|FSCK_HFS(8)||System Manager's Manual||FSCK_HFS(8)|
fsck.hfs — HFS
file system consistency check
fsck.hfs utility verifies and repairs
standard HFS and HFS+ file systems.
The first form of
fsck.hfs quickly checks
the specified file systems to determine whether they were cleanly
The second form of
fsck.hfs preens the
specified file systems. It is normally started by fsck(8)
during systen boot, when a HFS file system is detected. When preening file
fsck.hfs will fix common inconsistencies
for file systems that were not unmounted cleanly. If more serious problems
fsck.hfs does not try to fix them,
indicates that it was not successful, and exits.
The third form of
fsck.hfs checks the
specified file systems and tries to repair all detected inconsistencies.
If no options are specified
always check and attempt to fix the specified file systems.
The options are as follows:
- Specify the size of the cache used by
fsck.hfsinternally. Bigger size can result in better performance but can result in deadlock when used with
-loption. Size can be specified as a decimal, octal, or hexadecimal number. If the number ends with a ``k'', ``m'', or ``g'', the number is multiplied by 1024 (1K), 1048576 (1M), or 1073741824 (1G), respectively.
- Display debugging information. This option may provide useful information
fsck.hfscannot repair a damaged file system.
- When used with the
fsck.hfsto check `clean' file systems, otherwise it means force
fsck.hfsto check and repair journaled HFS+ file systems.
fsck.hfsto generate its output strings in GUI format. This option is used when another application with a graphical user interface (like Mac OS X Disk Utility) is invoking the
- Lock down the file system and perform a test-only check. This makes it possible to check a file system that is currently mounted, although no repairs can be made.
- Mode is an octal number that will be used to set the permissions for the
lost+found directory when it is created. The lost+found directory is only
created when a volume is repaired and orphaned files or directories are
fsck.hfsplaces orphaned files and directories into the lost+found directory (located at the root of the volume). The default mode is 01777.
- Preen the specified file systems.
fsck.hfsto quickly check whether the volume was unmounted cleanly. If the volume was unmounted cleanly, then the exit status is 0. If the volume was not unmounted cleanly, then the exit status will be non-zero. In either case, a message is printed to standard output describing whether the volume was clean or dirty.
- Always attempt to repair any damage that is found.
- Never attempt to repair any damage that is found.
- Rebuild the catalog file on the specified file system. This option currently will only work if there is enough contiguous space on the specified file system for a new catalog file and if there is no damage to the leaf nodes in the existing catalog file.
fsck.hfs is not able to fix some
inconsistencies that it detects.
fsck.hfs command appeared in Mac OS X
Server 1.0 .
|November 21, 2002||Mac OS X|