|ZONE(9)||Kernel Developer's Manual||ZONE(9)|
int size, uma_ctor ctor,
uma_dtor dtor, uma_init uminit,
uma_fini fini, int align,
zone, void *arg,
zone, void *item,
zone, const char
The zone allocator provides an efficient interface for managing dynamically-sized collections of items of similar size. The zone allocator can work with preallocated zones as well as with runtime-allocated ones, and is therefore available much earlier in the boot process than other memory management routines.
A zone is an extensible collection of items of identical size. The zone allocator keeps track of which items are in use and which are not, and provides functions for allocating items from the zone and for releasing them back (which makes them available for later use).
After the first allocation of an item, it will have been cleared to zeroes, however subsequent allocations will retain the contents as of the last free.
function creates a new zone from which items may then be allocated from. The
name argument is a text name of the zone for debugging
and stats; this memory should not be freed until the zone has been
The ctor and
dtor arguments are callback functions that are called
by the uma subsystem at the time of the call to
uma_zfree() respectively. Their purpose is to
provide hooks for initializing or destroying things that need to be done at
the time of the allocation or release of a resource. A good usage for the
ctor and dtor callbacks might be
to adjust a global count of the number of objects allocated.
The uminit and
fini arguments are used to optimize the allocation of
objects from the zone. They are called by the uma subsystem whenever it
needs to allocate or free several items to satisfy requests or memory
pressure. A good use for the uminit and
fini callbacks might be to initialize and destroy
mutexes contained within the object. This would allow one to re-use already
initialized mutexes when an object is returned from the uma subsystem's
object cache. They are not called on each call to
uma_zfree() but rather in a batch mode on
The flags argument of the
is a subset of the following flags:
- Slabs of the zone are never returned back to VM.
- Each item in the zone would have internal reference counter associated
with it. See
- Pages belonging to the zone will not be included into mini-dumps.
- An allocation from zone would have mp_ncpu shadow
copies, that are privately assigned to CPUs. A CPU can address its private
copy using base allocation address plus multiple of current CPU id and
foo_zone = uma_zcreate(..., UMA_ZONE_PCPU); ... foo_base = uma_zalloc(foo_zone, ...); ... critical_enter(); foo_pcpu = (foo_t *)zpcpu_get(foo_base); /* do something with foo_pcpu */ critical_exit();
- By default book-keeping of items within a slab is done in the slab page
itself. This flag explicitly tells subsystem that book-keeping structure
should be allocated separately from special internal zone. This flag
UMA_ZONE_HASH, since subsystem requires a mechanism to find a book-keeping structure to an item being freed. The subsystem may choose to prefer offpage book-keeping for certain zones implicitly.
- The zone will have its uma_init method set to
internal method that initializes a new allocated slab to all zeros. Do not
mistake uma_init method with
uma_ctor. A zone with
UMA_ZONE_ZINITflag would not return zeroed memory on every
- The zone should use an internal hash table to find slab book-keeping structure where an allocation being freed belongs to.
- The zone should use special field of vm_page_t to find slab book-keeping structure where an allocation being freed belongs to.
- The zone is for the malloc(9) subsystem.
- The zone is for the VM subsystem.
To allocate an item from a zone, simply call
with a pointer to that zone and set the flags argument
to selected flags as documented in malloc(9). It will
return a pointer to an item if successful, or
in the rare case where all items in the zone are in use and the allocator is
unable to grow the zone and
Items are released back to the zone from which they
were allocated by calling
with a pointer to the zone and a pointer to the item. If
uma_zfree() does nothing.
If zone was created with
UMA_ZONE_REFCNT flag, then pointer to reference
counter for an item can be retrieved with help of the
Created zones, which are empty, can be destroyed
freeing all memory that was allocated for the zone. All items allocated from
the zone with
uma_zalloc() must have been freed with
function limits the number of items (and therefore memory) that can be
allocated to zone. The nitems
argument specifies the requested upper limit number of items. The effective
limit is returned to the caller, as it may end up being higher than
requested due to the implementation rounding up to ensure all memory pages
allocated to the zone are utilised to capacity. The limit applies to the
total number of items in the zone, which includes allocated items, free
items and free items in the per-cpu caches. On systems with more than one
CPU it may not be possible to allocate the specified number of items even
when there is no shortage of memory, because all of the remaining free items
may be in the caches of the other CPUs when the limit is hit.
function returns the effective upper limit number of items for a zone.
function returns the approximate current occupancy of the zone. The returned
value is approximate because appropriate synchronisation to determine an
exact value is not performed by the implementation. This ensures low
overhead at the expense of potentially stale data being used in the
function sets a warning that will be printed on the system console when the
given zone becomes full and fails to allocate an item. The warning will be
printed no more often than every five minutes. Warnings can be turned off
globally by setting the vm.zone_warnings sysctl
tunable to 0.
function sets a function that will be called when the given zone becomes
full and fails to allocate an item. The function will be called with the
zone locked. Also, the function that called the allocation function may have
held additional locks. Therefore, this function should do very little work
(similar to a signal handler).
descr) macro declares a static
sysctl oid that exports the effective upper limit number
of items for a zone. The zone argument should be a
pointer to uma_zone_t. A read of the oid returns value
uma_zone_get_max(). A write to the
oid sets new value via
zone, descr) macro is provided
to create this type of oid dynamically.
descr) macro declares a static read-only
sysctl oid that exports the approximate current occupancy
of the zone. The zone argument should be a pointer to
uma_zone_t. A read of the oid returns value obtained
descr) macro is provided to create this type of oid
uma_zalloc() function returns a
pointer to an item, or
NULL if the zone ran out of
unused items and
M_NOWAIT was specified.
The zone allocator first appeared in FreeBSD 3.0. It was radically changed in FreeBSD 5.0 to function as a slab allocator.
The zone allocator was written by John S. Dyson. The zone allocator was rewritten in large parts by Jeff Roberson <jeff@FreeBSD.org> to function as a slab allocator.
|December 20, 2015||Debian|