table of contents
|SND_SBC(4)||Device Drivers Manual||SND_SBC(4)|
snd_sb8 — Creative Sound
Blaster ISA and compatible bridge device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5):
snd_sbc_load="YES" snd_sb16_load="YES" snd_sb8_load="YES"
Non-PnP cards require the following lines in device.hints(5):
hint.sbc.0.at="isa" hint.sbc.0.port="0x220" hint.sbc.0.irq="5" hint.sbc.0.drq="1" hint.sbc.0.flags="0x15"
snd_sbc bridge driver allows the
generic audio driver sound(4) to attach to Creative Sound
Blaster ISA (mostly SB16 or SB8, known as SoundBlaster Pro) compatible audio
The value of flags specifies the secondary DMA channel. If the secondary DMA channel is C, set the flags to (C | 0x10). For a sound card without the secondary DMA channel, the flags should be set to zero.
snd_sbc driver supports the following
- Avance Asound 110
- Avance Logic ALS100+
- Avance Logic ALS120
- Creative SB16
- Creative SB32
- Creative AWE64
- Creative AWE64 Gold
- Creative ViBRA16C
- Creative ViBRA16X
- ESS ES1681
- ESS ES1688
- ESS ES1868
- ESS ES1869
- ESS ES1878
- ESS ES1879
- ESS ES1888
- sb_dspwr(XX) timed out.
- A command to the DSP has timed out. Check the I/O port configuration.
- bad irq XX (5/7/9/10 valid)
- The IRQ given to the driver is not valid.
snd_sbc device driver first appeared
in FreeBSD 4.0.
Seigo Tanimura <firstname.lastname@example.org>
|February 17, 2007||Debian|