table of contents
|SES(4)||Device Drivers Manual||SES(4)|
ses — SCSI
Environmental Services driver
ses driver provides support for all
SCSI devices of the environmental services class that are attached to the
system through a supported SCSI Host Adapter, as well as emulated support
for SAF-TE (SCSI Accessible Fault Tolerant Enclosures). The environmental
services class generally are enclosure devices that provide environmental
information such as number of power supplies (and state), temperature,
device slots, and so on.
A SCSI Host adapter must also be separately configured into the system before a SCSI Environmental Services device can be configured.
It is only necessary to explicitly configure one
ses device; data structures are dynamically
allocated as devices are found on the SCSI bus.
A separate option, SES_ENABLE_PASSTHROUGH,
may be specified to allow the
ses driver to perform
functions on devices of other classes that claim to also support
The following ioctl(2) calls apply to
ses devices. They are defined in the header file
- Used to find out how many
seselements are driven by this particular device instance.
- Read, from the kernel, an array of SES elements which contains the element
identifier, which subenclosure it is in, and the
sestype of the element.
- Get the overall enclosure status.
- Set the overall enclosure status.
- Get the status of a particular element.
- Set the status of a particular element.
- Get the associated help text for an element (not yet implemented).
sesdevices often have descriptive text for an element which can tell you things like location (e.g., "left power supply").
- Initialize the enclosure.
- Get the element's descriptor string.
- Get the device names, if any, associated with this element.
- Used to read the SES String In Diagnostic Page. The contents of this page are device-specific.
- Used to set the SES String Out Diagnostic Page. The contents of this page are device-specific.
- Used to get the name of the enclosure.
- Used to get the Enclosure Logical Identifier.
The files contained in
show simple mechanisms for how to use these interfaces, as well as a very
stupid simple monitoring daemon.
- The Nth
When the kernel is configured with DEBUG enabled, the first open to an SES device will spit out overall enclosure parameters to the console.
ses driver was originally written for
the CAM SCSI subsystem by Matthew Jacob and first released in
FreeBSD 4.3. It was a functional equivalent of a
similar driver available in Solaris, Release 7. It was largely rewritten by
Alexander Motin, Justin Gibbs, and Will Andrews for FreeBSD
|November 12, 2019||Debian|