|NG_RFC1490(4)||Device Drivers Manual||NG_RFC1490(4)|
rfc1490node type performs protocol encapsulation, de-encapsulation, and multiplexing according to RFC 1490 (which has since been updated by RFC 2427). This particular type of encapsulation is often used on top of frame relay DLCI channels.
downstream hook is used to transmit
and receive encapsulated frames. On the other side of the node, the
ppp hooks are used
to transmit and receive raw IP frames and PPP frames, respectively. PPP
frames are transmitted and received according to RFC 1973; in particular,
frames appearing on the
ppp hook begin with the PPP
protocol number. The
ethernet hook can be used to
transmit and receive Ethernet frames (without a checksum) in RFC 1490's
inet hook is connected to
inet hook of an ng_iface(4)
HOOKS¶This node type supports the following hooks:
- Connects to the RFC 1490 peer entity.
- Transmits and receives bridged raw Ethernet frames, without a checksum.
- Transmits and receives raw IP frames.
- Transmits and receives PPP frames.
CONTROL MESSAGES¶This node type supports the generic control messages, plus the following:
- This command sets encapsulation method for the node. The desired method
must be passed as a string message argument, and must be one of the
following supported encapsulation modes:
- IP packets are sent using simple RFC1490/2427 encapsulation.
- IP packets are sent inside SNAP frames. Also conforms to RFC1490/2427.
- IP packets are sent and received using proprietary Cisco encapsulation method.
- This command returns current encapsulation method on the node.
SHUTDOWN¶This node shuts down upon receipt of a
NGM_SHUTDOWNcontrol message, or when all hooks have been disconnected.
SEE ALSO¶netgraph(4), ng_frame_relay(4), ng_iface(4), ngctl(8)
C. Brown and A. Malis, Multiprotocol Interconnect over Frame Relay, RFC 2427.
W. Simpson, PPP in Frame Relay, RFC 1973.
ng_rfc1490node type was implemented in FreeBSD 4.0.
AUTHORS¶Julian Elischer <julian@FreeBSD.org>
BUGS¶Not all of RFC 1490 is implemented.
|January 19, 1999||Linux 4.19.0-10-amd64|