|EX(4)||Device Drivers Manual (i386)||EX(4)|
ex — Ethernet
device driver for the Intel EtherExpress Pro/10 and Pro/10+
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
ex driver is not present in
FreeBSD 13.0 and later. See
https://github.com/freebsd/fcp/blob/master/fcp-0101.md for more
ex driver provides support for
Ethernet adapters based on the Intel i82595 chip.
On the ISA bus, the card will be searched for in the I/O address range 0x200 - 0x3a0. The IRQ will be read from the EEPROM on the card. For correct operation Plug-N-Play support should be disabled.
On the PC Card bus, the card will be automatically recognized and configured.
ex driver supports the following
- Intel EtherExpress Pro/10 ISA
- Intel EtherExpress Pro/10+ ISA
- Olicom OC2220 Ethernet PC Card
- Olicom OC2232 Ethernet/Modem PC Card
- Silicom Ethernet LAN PC Card
- Silicom EtherSerial LAN PC Card
- ex%d: Intel EtherExpress Pro/10, address %6D, connector %s
- The device probe found an installed card, and was able to correctly install the device driver.
- ex%d: WARNING: board's EEPROM is configured for IRQ %d, using %d
- The device probe detected that the board is configured for a different interrupt than the one specified in the kernel configuration file.
- ex%d: invalid IRQ.
- The device probe detected an invalid IRQ setting.
ex device driver first appeared in
ex device driver was written by
Javier Martín Rueda. The PC Card attachment
was written by Mitsuru ISAWAKI and
Warner Losh. This manual page was written by
David E. O'Brien.
Currently the driver does not support multicast.
The Silicom EtherSerial card's serial port does not currently
work. The Olicom OC2232 PC Card should work with the
ex driver, but is currently completely broken.
|October 24, 2018||Debian|