|NG_TTY(4)||Device Drivers Manual||NG_TTY(4)|
ttynode type is both a netgraph node type and a TTY hook.
The node has a single hook called
Incoming bytes received on the tty device are sent out on this hook, and
frames received on
hook are transmitted out on the
tty device. No modification to the data is performed in either direction.
While the hook is installed on a tty, the normal read and write operations
are unavailable, returning
Incoming data is delivered directly to ng_tty via the tty bypass hook as a buffer pointer and length, this is converted to a mbuf and passed to the peer.
The node supports an optional “hot character”. If
the driver can not deliver data directly to the tty bypass hook then each
character is input one at a time. If set to non-zero and bypass mode is
unavailable, incoming data from the tty device is queued until this
character is seen. This avoids sending lots of mbufs containing a small
number of bytes, but introduces potentially infinite latency. The default
hot character is 0x7e, consistent with
connected to a ng_async(4) type node. The hot character
has no effect on the transmission of data.
HOOKS¶This node type supports the following hooks:
- tty(4) serial data contained in
mbufstructures, with arbitrary inter-frame boundaries.
CONTROL MESSAGES¶This node type supports the generic control messages, plus the following:
- This command takes an integer argument and sets the hot character from the lower 8 bits. A hot character of zero disables queueing, so that all received data is forwarded immediately.
- Returns an integer containing the current hot character in the lower eight bits.
- This command takes integer process ID and file descriptor of open tty and registers the tty hooks.
SHUTDOWN¶This node shuts down when the corresponding device is closed.
SEE ALSO¶ioctl(2), netgraph(4), ng_async(4), tty(4), ngctl(8)
ng_ttynode type was implemented in FreeBSD 4.0.
AUTHORS¶Archie Cobbs <archie@FreeBSD.org>
Andrew Thompson <thompsa@FreeBSD.org>
BUGS¶The serial driver code also has a notion of a “hot character”. Unfortunately, this value is statically defined in terms of the line discipline and cannot be changed. Therefore, if a hot character other than 0x7e (the default) is set for the
ng_ttynode, the node has no way to convey this information to the serial driver, and sub-optimal performance may result.
|December 25, 2008||Linux 4.9.0-9-amd64|