Scroll to navigation

MPS(4) Device Drivers Manual MPS(4)

NAME

mps
LSI Fusion-MPT 2 IT/IR 6Gb/s Serial Attached SCSI/SATA driver

SYNOPSIS

To compile this driver into the kernel, place these lines in the kernel configuration file:
device pci
device scbus
device mps

The driver can be loaded as a module at boot time by placing this line in loader.conf(5):

mps_load="YES"

DESCRIPTION

The mps driver provides support for Broadcom Ltd./Avago Tech (LSI) Fusion-MPT 2 IT/IR SAS controllers and WarpDrive solid state storage cards.

HARDWARE

These controllers are supported by the mps driver:

  • Broadcom Ltd./Avago Tech (LSI) SAS 2004 (4 Port SAS)
  • Broadcom Ltd./Avago Tech (LSI) SAS 2008 (8 Port SAS)
  • Broadcom Ltd./Avago Tech (LSI) SAS 2108 (8 Port SAS)
  • Broadcom Ltd./Avago Tech (LSI) SAS 2116 (16 Port SAS)
  • Broadcom Ltd./Avago Tech (LSI) SAS 2208 (8 Port SAS)
  • Broadcom Ltd./Avago Tech (LSI) SAS 2308 (8 Port SAS)
  • Broadcom Ltd./Avago Tech (LSI) SSS6200 Solid State Storage
  • Intel Integrated RAID Module RMS25JB040
  • Intel Integrated RAID Module RMS25JB080
  • Intel Integrated RAID Module RMS25KB040
  • Intel Integrated RAID Module RMS25KB080

CONFIGURATION

In all tunable descriptions below, X represents the adapter number.

To disable MSI interrupts for all mps driver instances, set this tunable value in loader.conf(5):

hw.mps.disable_msi=1

To disable MSI interrupts for a specific mps driver instance, set this tunable value in loader.conf(5):

dev.mps.X.disable_msi=1

To disable MSI-X interrupts for all mps driver instances, set this tunable value in loader.conf(5):

hw.mps.disable_msix=1

To disable MSI-X interrupts for a specific mps driver instance, set this tunable value in loader.conf(5):

dev.mps.X.disable_msix=1

To set the maximum number of DMA chains allocated for all adapters, set this tunable in loader.conf(5):

hw.mps.max_chains=NNNN

To set the maximum number of DMA chains allocated for a specific adapter, set this tunable in loader.conf(5):

dev.mps.X.max_chains=NNNN

The default max_chains value is 2048.

The current number of free chain frames is stored in the dev.mps.X.chain_free sysctl(8) variable.

The lowest number of free chain frames seen since boot is stored in the dev.mps.X.chain_free_lowwater sysctl(8) variable.

The number of times that chain frame allocations have failed since boot is stored in the dev.mps.X.chain_alloc_fail sysctl(8) variable. This can be used to determine whether the max_chains tunable should be increased to help performance.

The current number of active I/O commands is shown in the dev.mps.X.io_cmds_active sysctl(8) variable.

To set the maximum number of pages that will be used per I/O for all adapters, set this tunable in loader.conf(5):

hw.mps.max_io_pages=NNNN

To set the maximum number of pages that will be used per I/O for a specific adapter, set this tunable in loader.conf(5):

dev.mps.X.max_io_pages=NNNN

The default max_io_pages value is -1, meaning that the maximum I/O size that will be used per I/O will be calculated using the IOCFacts values stored in the controller. The lowest value that the driver will use for max_io_pages is 1, otherwise IOCFacts will be used to calculate the maximum I/O size. The smaller I/O size calculated from either max_io_pages or IOCFacts will be the maximum I/O size used by the driver.

The highest number of active I/O commands seen since boot is stored in the dev.mps.X.io_cmds_highwater sysctl(8) variable.

Devices can be excluded from mps control for all adapters by setting this tunable in loader.conf(5):

hw.mps.exclude_ids=Y

Y represents the target ID of the device. If more than one device is to be excluded, target IDs are separated by commas.

Devices can be excluded from mps control for a specific adapter by setting this tunable in loader.conf(5):

dev.mps.X.exclude_ids=Y

Y represents the target ID of the device. If more than one device is to be excluded, target IDs are separated by commas.

The adapter can issue the StartStopUnit SCSI command to SATA direct-access devices during shutdown. This allows the device to quiesce powering down. To control this feature for all adapters, set the

hw.mps.enable_ssu

tunable in loader.conf(5) to one of these values:

0
Do not send SSU to either HDDs or SSDs.
1
Send SSU to SSDs, but not to HDDs. This is the default value.
2
Send SSU to HDDs, but not to SSDs.
3
Send SSU to both HDDs and SSDs.

To control the feature for a specific adapter, set this tunable value in loader.conf(5):

dev.mps.X.enable_ssu

The same set of values are valid when setting this tunable for all adapters.

SATA disks that take several seconds to spin up and fail the SATA Identify command might not be discovered by the driver. This problem can sometimes be overcome by increasing the value of the spinup wait time in loader.conf(5) with the

hw.mps.spinup_wait_time=NNNN

tunable. NNNN represents the number of seconds to wait for SATA devices to spin up when the device fails the initial SATA Identify command.

Spinup wait times can be set for specific adapters in loader.conf(5): with the

dev.mps.X.spinup_wait_time=NNNN

tunable. NNNN is the number of seconds to wait for SATA devices to spin up when they fail the initial SATA Identify command.

DEBUGGING

To enable debugging prints from the mps driver, set the
hw.mps.X.debug_level

tunable, either in loader.conf(5) or by using sysctl(8). These bits have the described effects:

0x0001 Enable informational prints (set by default).
0x0002 Enable prints for driver faults (set by default).
0x0004 Enable prints for controller events.
0x0008 Enable prints for controller logging.
0x0010 Enable prints for tracing recovery operations.
0x0020 Enable prints for parameter errors and programming bugs.
0x0040 Enable prints for system initialization operations.
0x0080 Enable prints for more detailed information.
0x0100 Enable prints for user-generated commands (IOCTL).
0x0200 Enable prints for device mapping.
0x0400 Enable prints for tracing through driver functions.

SEE ALSO

cam(4), cd(4), ch(4), da(4), mpr(4), mpt(4), pci(4), sa(4), scsi(4), targ(4), loader.conf(5), sysctl(8)

HISTORY

The mps driver first appeared in FreeBSD 9.3.

AUTHORS

The mps driver was originally written by Scott Long <scottl@FreeBSD.org>. It has been improved and tested by LSI Corporation, Avago Technologies (formally LSI), and Broadcom Ltd. (formally Avago).

This man page was written by Ken Merry <ken@FreeBSD.org> with additional input from Stephen McConnell <slm@FreeBSD.org>.

July 5, 2016 Linux 4.9.0-9-amd64