|CTAU(4)||Device Drivers Manual (i386)||CTAU(4)|
ctaudriver needs either sppp(4) or netgraph(4). Which one to use is determined by the
NETGRAPH_CRONYXoption. If this option is present in your kernel configuration file, the
ctaudriver will be compiled with netgraph(4) support. Otherwise, it will be compiled with sppp(4) support.
The base I/O port address specified in /boot/device.hints must match the port address set by the jumpers on the board. The DMA I/O channel and interrupt request numbers are configured by software at adapter initialization. Legal values are:
- 0x200, 0x220, 0x240, 0x260, 0x280, 0x2a0, 0x2c0, 0x2e0, 0x300, 0x320, 0x340, 0x360, 0x380, 0x3a0, 0x3c0, 0x3e0
- 3, 5, 7, 10, 11, 12, 15
- 5, 6, 7
ctau driver supports autodetection. As
for all non-PNP hardware, using autodetection could lead to some potential
problems with other devices during the hardware detection process. It is
always better to specify hardware resources manually.
Refer to sconfig(8) for information about the
ctau adapter configuration.
ctaudriver supports the following cards:
- Cronyx Tau (RS-232/V.35)
- Cronyx Tau/R (RS-530/RS-449)
- Cronyx Tau/E1 (fractional E1)
- Cronyx Tau/G703 (unframed E1)
SEE ALSO¶cp(4), cx(4), sppp(4), ifconfig(8), sconfig(8), spppcontrol(8)
ctaudriver was added in FreeBSD 5.3 and FreeBSD 4.10. The
ctaudriver for previous versions of FreeBSD is available from http://www.cronyx.ru/.
|September 6, 2004||Linux 4.9.0-9-amd64|