|DHCPCD.CONF(5)||File Formats Manual||DHCPCD.CONF(5)|
dhcpcdcan do everything from the command line, there are cases where it's just easier to do it once in a configuration file. Most of the options found in dhcpcd(8) can be used here. The first word on the line is the option and the rest of the line is the value. Leading and trailing whitespace for the option and value are trimmed. You can escape characters in the value using the \ character.
Blank lines and lines starting with # are ignored.
Here's a list of available options:
- When discovering interfaces, the interface name must match
pattern which is a space or comma separated list of
patterns passed to fnmatch(3). If the same interface is
denyinterfacesthen it is still denied.
- When discovering interfaces, the interface name must not match pattern which is a space or comma separated list of patterns passed to fnmatch(3).
dhcpcdwill arping each address in order before attempting DHCP. If an address is found, we will select the replying hardware address as the profile, otherwise the ip address. Example:interface bge0arping 192.168.0.1profile 192.168.0.1static ip_address=192.168.0.10/24
authprotocolprotocol algorithm rdm
- Authenticate DHCP messages. See the Supported Authentication Protocols section.
authtokensecretid realm expire key
- Define a shared key for use in authentication. realm can
be to for use with the delayed prptocol.
expire is the date the token expires and should be
formatted "yyy-mm-dd HH:MM". You can use the keyword
forever or 0 which means the
token never expires. For the token protocol,
secretid needs to be 0 and
realm needs to be "". If
dhcpcdhas the errordhcp_auth_encode: Invalid argumentthen it means that
dhcpcdcould not find the correct authentication token in your configuration.
- Background immediately. This is useful for startup scripts which don't disable link messages for carrier status.
- Ignores all packets from address[/cidr].
- Only accept packets from address[/cidr].
blacklistis ignored if
- Be a BOOTP client. Basically, this just doesn't send a DHCP Message Type option and will only interact with a BOOTP server. All other DHCP options still work.
- Instructs the DHCP server to broadcast replies back to the client.
Normally this is only set for non Ethernet interfaces, such as FireWire
and InfiniBand. In most cases,
dhcpcdwill set this automatically.
- Sets the group ownership of /var/run/dhcpcd.sock
so that users other than root can connect to
- Echo debug messages to the stderr and syslog.
- Load the value /dev
dhcpcdwill load the first one found to work, if any.
- Push value to the environment for use in
dhcpcd-run-hooks(8). For example, you can force the
hostname hook to always set the hostname with
envforce_hostname=YES. Or set which driver wpa_supplicant(8) should use with
If the hostname is set, will be will set to the FQDN if possible as per RFC 4702 section 3.1. If the FQDN option is missing,
dhcpcdwill still try and set a FQDN from the hostname and domain options for consistency. To override this, set
envhostname_fqdn=[YES|NO|SERVER]. A value of server means just what the server says, don't manipulate it. This could lead to an inconsistent hostname on a DHCPv4 and DHCPv6 network where the DHCPv4 hostname is short and the DHCPv6 has an FQDN. DHCPv6 has no hostname option.
- Send the clientid. If the string is of the format
01:02:03 then it is encoded as hex. For interfaces whose hardware address
is longer than 8 bytes, or if the clientid is an
empty string then
dhcpcdsends a default clientid of the hardware family and the hardware address.
- Generate an RFC 4361.
compliant DHCP Unique Identifier. If persistent storage is available then
a DUID-LLT (link local address + time) is generated, otherwise DUID-LL is
generated (link local address). This, plus the IAID will be used as the
clientid. The DUID-LLT generated will be held in /etc/dhcpcd.duid and should not be copied to other hosts.
- Set the Interface Association Identifier to iaid.
This option must be used in an
interfaceblock. This defaults to the last 4 bytes of the hardware address assigned to the interface. Each instance of this should be unique within the scope of the client and
dhcpcdwarns if a conflict is detected. If there is a conflict, it is only a problem if the conflicted IAIDs are used on the same network.
- Enable DHCP on the interface, on by default.
- Enable DHCPv6 on the interface, on by default.
- Enable IPv4 on the interface, on by default.
- Enable IPv6 on the interface, on by default.
dhcpcdnormally de-configures the interface and configuration when it exits. Sometimes, this isn't desirable if, for example, you have root mounted over NFS or SSH clients connect to this host and they need to be notified of the host shutting down. You can use this option to stop this from happening.
- Fallback to using this profile if DHCP fails. This allows you to configure a static profile instead of using ZeroConf.
- Sends hostname to the DHCP server so it can be registered in DNS. If hostname is an empty string then the current system hostname is sent. If hostname is a FQDN (ie, contains a .) then it will be encoded as such.
- Sends the short hostname to the DHCP server instead of the FQDN. This is
useful because DHCP servers will not register the FQDN in their DNS if the
domain part does not match theirs.
Also, see the
envoption above to control how the hostname is set on the host.
ia_na[iaid [/ address]]
- Request a DHCPv6 Normal Address for iaid.
iaid defaults to the
iaidoption as described above. You can request more than one ia_na by specifying a unique iaid for each one.
- Request a DHCPv6 Temporary Address for iaid. You can request more than one ia_ta by specifying a unique iaid for each one.
ia_pd[iaid [/ prefix / prefix_len] [interface [/ sla_id [/ prefix_len]]]]
- Request a DHCPv6 Delegated Prefix for iaid. This
option must be used in an
interfaceblock. Unless a sla_id of 0 is assigned, a reject route is installed for the Delegated Prefix to stop unallocated addresses being resolved upstream. This reject route is in essence SLA 0, thus you need space within the prefix to assign a SLA per interface. If no interface is given then we will assign a prefix to every other interface with a sla_id equivalent to the interface index assigned by the OS. Otherwise addresses are only assigned for each interface and sla_id. Each assigned address will have a suffix of 1. You cannot assign a prefix to the requesting interface unless the DHCPv6 server supports
RFC6603Prefix Exclude Option.
dhcpcdhas to be running for all the interfaces it is delegating to. A default prefix_len of 64 is assumed, unless the maximum sla_id does not fit. In this case prefix_len is increased to the highest multiple of 8 that can accommodate the sla_id. sla_id is an integer and is added to the prefix which must fit inside prefix_len less the length of the delegated prefix. sla_id can be 0 only if the Delegated Prefix is assigned to one interface. You can specify multiple interface / sla_id / prefix_len per
ia_pd, space separated. IPv6RS should be disabled globally when requesting a Prefix Delegation.
In the following example eth0 is the externally facing interface to be configured for both IPv4 and IPv6. The DHCPv4 server will provide us with an IPv4 address and a default route. The DHCPv6 server is going to provide us with an IPv6 address, a default route and a /64 subnet to be delegated to the internal interface. The eth1 interface will be automatically configured for IPv6 using the first address (::1) from the delegated prefix. A second prefix is requested and assigned to two other interfaces. rtadvd(8) can be used with an empty configuration file on eth1, eth2 and eth3, to provide automatic IPv6 address configuration for the internal network.
noipv6rs # disable routing solicitation denyinterfaces eth2 # Don't touch eth2 at all interface eth0 ipv6rs # enable routing solicitation get the # default IPv6 route ia_na 1 # request an IPv6 address ia_pd 2 eth1/0 # request a PD and assign it to eth1 ia_pd 3 eth2/1 eth3/2 # req a PD and assign it to eth2 and eth3 # we cannot use SLA 0 above because we are # assinging the PD to more than one interface
- Only configure IPv4.
- Only confgiure IPv6.
fqdn[disable | ptr | both]
- ptr just asks the DHCP server to update the PTR record of the host in DNS
whereas both also updates the A record. disable will disable the FQDN
option. The default is both.
dhcpcditself never does any DNS updates.
dhcpcdencodes the FQDN hostname as specified in
- Subsequent options are only parsed for this interface.
- Generate SLAAC addresses for each Prefix advertised by a Router Advertisement message with the Auto flag set. On by default.
- Disables the above option.
- By default, when
dhcpcdreceives an IPv6 RA,
dhcpcdwill only fork to the background if the RA contains at least one unexpired RDNSS option and a valid prefix or no DHCPv6 instruction. Set this option so to make
dhcpcdalways fork on an RA.
- Disables kernel IPv6 Router Advertisement processing so dhcpcd can manage addresses and routes.
- Each time dhcpcd receives an IPv6 Router Adveristment, dhcpcd will manage the default route only. This allows dhcpcd to prefer an interface for outbound traffic based on metric and/or user selection rather than the kernel.
- Some IPv6 routers advertise themselves as a default router without any
public prefixes or managed addresses. Generally, this is incorrect
dhcpcdwill ignore the advertisement unless this option is turned on.
- Enables IPv6 Router Advertisement solicitation. This is on by default, but is documented here in the case where it is disabled globally but needs to be enabled for one interface.
- Request a leasetime of seconds.
- Writes to the specified logfile rather than
syslog(3). The logfile is
truncated when opened and is reopened when
- Metrics are used to prefer an interface over another one, lowest wins.
dhcpcdwill supply a default metric of 200 + if_nametoindex(3). An extra 100 will be added for wireless interfaces.
- Any pre-existing IPv4 addresses existing address will be removed from the interface when adding a new IPv4 address.
- Don't send any ARP requests. This also disables IPv4LL.
- Don't require authentication even though we requested it. Also allows FORCERENEW and RECONFIGURE messages without authentication.
- Don't delay for an initial randomised time when starting protocols.
- Don't load /dev management modules.
- Don't start DHCP or listen to DHCP messages. This is only useful when allowing IPv4LL.
- Don't start DHCPv6 or listen to DHCPv6 messages. Normally DHCPv6 is started by a RA instruction or configuration.
- Don't install any default routes.
- Install a default route if available (default).
- Don't run this hook script. Matches full name, or prefixed with 2 numbers
optionally ending with .sh.
So to stop
dhcpcdfrom touching your DNS settings or starting wpa_supplicant you would do:-nohook resolv.conf, wpa_supplicant
- Don't attempt to configure an IPv4 address.
- Don't attempt to obtain an IPv4LL address if we failed to get one via DHCP. See RFC 3927.
- Don't attmept to configure an IPv6 address.
- Disable solicitation and receipt of IPv6 Router Advertisements.
- Don't receive link messages about carrier status. You should only set this for buggy interface drivers.
- Don't bring the interface up when in master mode. If
dhcpcd.confcannot determine the carrier state,
dhcpcd.confwill enter a tight polling loop until the interface is marked up and running or a valid carrier state is reported.
- Requests the option from the server. It can be a
variable to be used in dhcpcd-run-hooks(8) or the
numerical value. You can specify more options
separated by commas, spaces or more
optionlines. option Prepend dhcp6_ to option to request a DHCPv6 option. If no DHCPv6 options are configured, then DHCPv4 options are mapped to equivalent DHCPv6 options.
Prepend nd_ to option to handle ND options, but this only works for the
- Remove the option from the message before it's processed.
- Requires the option to be present in all messages,
otherwise the message is ignored. To enforce that
dhcpcdonly responds to DHCP servers and not BOOTP servers, you can
requiredhcp_message_type. This isn't an exact science though because a BOOTP server can send DHCP like options.
- Reject a message that contains the option. This is
useful when you cannot use
requireto select / de-select BOOTP messages.
dhcpcd.confdetects an address added to a point to point interface (PPP, TUN, etc) then it will set the listed DHCP options to the destination address of the interface.
- Subsequent options are only parsed for this profile name.
- Suppress any dhcpcd output to the console, except for errors.
- Allow reboot seconds before moving to the DISCOVER
phase if we have an old lease to use and moving from DISCOVER to IPv4LL if
no reply. The default is 5 seconds. A setting of 0 seconds causes
dhcpcdto skip the REBOOT phase and go straight into DISCOVER. This is desirable for mobile users because if you change from network A to network B and they use the same subnet and the address from network A isn't in use on network B, then the DHCP server will remain silent even if authoritative which means
dhcpcdwill timeout before moving back to the DISCOVER phase.
dhcpcdwill release the lease prior to stopping the interface.
- Use script instead of the default /lib/dhcpcd/dhcpcd-run-hooks.
- Subsequent options are only parsed for this wireless ssid.
slaac[hwaddr | private]
- Selects the interface identifier used for SLAAC generated IPv6 addresses. If private is used, a RFC7217 address is generated.
- Configures a static value. If you set
dhcpcdwill not attempt to obtain a lease and just use the value for the address with an infinite lease time.
Here is an example which configures a static address, routes and dns.interface eth0static ip_address=192.168.0.10/24static routers=192.168.0.1static domain_name_servers=192.168.0.1
Here is an example for PPP which gives the destination a default route. It uses the special destination keyword to insert the destination address into the value.interface ppp0static ip_address=destination routers
- Timeout after seconds, instead of the default 30. A
setting of 0 seconds causes
dhcpcdto wait forever to get a lease. If
dhcpcdis working on a single interface then
dhcpcdwill exit when a timeout occurs, otherwise
dhcpcdwill fork into the background. If using IPv4LL then
dhcpcdstart the IPv4LL process after the timeout and then wait a little longer before really timing out.
- Tag the DHCPv4 messages with the userclass. You can specify more than one.
- Add an encapsulated vendor option. code should be
between 1 and 254 inclusive. To add a raw vendor string, omit
code but keep the comma. Examples.
Set the vendor option 01 with an IP address.vendor 01,192.168.0.2Set the vendor option 02 with a hex code.vendor 02,01:02:03:04:05Set the vendor option 03 with an IP address as a string.vendor 03,\"192.168.0.2\"Set un-encapsulated vendor option to hello world.vendor ,"hello world"
- Set the DHCP Vendor Class. DHCPv6 has it's own option as shown below. The
dhcpcd-5.5.6:NetBSD-6.99.5:i386:i386If not set then none is sent. Some badly configured DHCP servers reject unknown vendorclassids. To work around it, try and impersonate Windows by using the MSFT vendorclassid.
- Add the DHCPv6 Vendor Indetifying Vendor Class with the IANA assigned Enterprise Number en with the data. This option can be set more than once to add more data, but the behaviour, as per RFC(3925) is undefined if the Enterprise Number differs.
waitip[4 | 6]
- Wait for an address to be assigned before forking to the background. 4
means wait for an IPv4 address to be assigned. 6 means wait for an IPv6
address to be assigned. If no argument is given,
dhcpcd.confwill wait for any address protocol to be assigned. It is possible to wait for more than one address protocol and
dhcpcd.confwill only fork to the background when all waiting conditions are satisfied.
- Use the last four bytes of the hardware address as the DHCP xid instead of a randomly generated number.
Defining new options¶DHCP, ND and DHCPv6 allow for the use of custom options. Each option needs to be started with the
define6directive. This can optionally be followed by both
encapoptions. Both can be specified more than once and
embedmust come before
definecode type variable
- Defines the DHCP option code of type with a name of variable exported to dhcpcd-run-hooks(8).
definendcode type variable
- Defines the ND option code of type with a name of variable exported to dhcpcd-run-hooks(8), with a prefix of _nd.
define6code type variable
- Defines the DHCPv6 option code of type with a name of variable exported to dhcpcd-run-hooks(8), with a prefix of _dhcp6.
vendoptcode type variable
- Defines the Vendor-Identifying Vendor Options. The code is the IANA Enterprise Number which will unqiuely describe the encapsulated options. type is normally encap. variable names the Vendor option to be exported.
- Defines an embedded variable within the defined option. The length is determined by the type. If the variable is not the same as defined in the parent option, it is prefixed with the parent variable first with an underscore. If the variable has the name of reserved then it is not processed.
encapcode type variable
- Defines an encapsulated variable within the defined option. The length is determined by the type. If the variable is not the same as defined in the parent option, it is prefixed with the parent variable first with an underscore.
Type prefix¶These keywords come before the type itself, to describe it more fully. You can use more than one, but they must appear in the order listed below.
- Requests the option by default without having to be specified in user configuration
- This option cannot be requested, regardless of user configuration
- This option is optional. Only makes sense for embedded options where like the client FQDN option where the FQDN string itself is optional.
- The option can appear more than once and will be indexed.
- The option data is split into a space separated array, each element being the same type.
Types to define¶The type directly affects the length of data consumed inside the option. Any remaining data is normally discarded. Lengths can be specified for string and binhex types, but this is generally with other data embedded afterwards in the same option.
- An IPv4 address, 4 bytes.
- An IPv6 address, 16 bytes.
- A NVT ASCII string of printable characters.
- A byte.
- A byte represented as a string of flags, most significant bit first. For example, using ABCDEFGH then A would equal 10000000, B 01000000, C 00100000, etc. If the bit is not set, the flag is not printed. A flag of 0 is not printed even if the bit postition is set. This is to allow reservation of the first bits while assinging the last bits.
- A signed 16bit integer, 2 bytes.
- An unsigned 16bit integer, 2 bytes.
- A signed 32bit integer, 4 bytes.
- An unsigned 32bit integer, 4 bytes.
- A fixed value (1) to indicate that the option is present, 0 bytes.
- A RFC 3397 encoded string.
- A RFC 1035 validated string.
- Binary data expressed as hexadecimal.
- Contains embedded options (implies encap as well).
- Contains encapsulated options (implies embed as well).
- References an option from the global definition.
Supported Authentication Protocols¶
- Sends and expects the token with the secretid 0 and realm of "" in each message.
- Delayed Authentication.
dhcpcdwill send an authentication option with no key or MAC. The server will see this option, and select a key for
dhcpcd.conf, writing the realm and secretid in it.
dhcpcdwill then look for a non-expired token with a matching realm and secretid. This token is used to authenicate all other messages.
- Same as above, but without a realm.
Supported Authentication Algorithms¶If none specified,
hmac-md5is the default.
Supported Replay Detection Mechanisms¶If none specified,
monotonicis the default. If this is changed from what was previously used, or the means of calculating or storing it is broken then the DHCP server will probably have to have its notion of the clients Replay Detection Value reset.
SEE ALSO¶fnmatch(3), if_nametoindex(3), dhcpcd(8), dhcpcd-run-hooks(8)
AUTHORS¶Roy Marples <email@example.com>
BUGS¶Please report them to http://roy.marples.name/projects/dhcpcd
|October 19, 2015||Linux 4.9.0-9-amd64|