|DHCPCD(8)||System Manager's Manual||DHCPCD(8)|
dhcpcdis an implementation of the DHCP client specified in
dhcpcdgets the host information (IP address, routes, etc) from a DHCP server and configures the network interface of the machine on which it is running.
dhcpcdthen runs the configuration script which writes DNS information to resolvconf(8), if available, otherwise directly to /etc/resolv.conf. If the hostname is currently blank, (null) or localhost, or force_hostname is YES or TRUE or 1 then
dhcpcdsets the hostname to the one supplied by the DHCP server.
dhcpcdthen daemonises and waits for the lease renewal time to lapse. It will then attempt to renew its lease and reconfigure if the new lease changes when the lease beings to expire or the DHCP server sends message to renew early.
If any interface reports a working carrier then
dhcpcd will try and obtain a lease before forking to
the background, otherwise it will fork right away. This behaviour can be
modified with the
dhcpcd is also an implementation of the
BOOTP client specified in
dhcpcd is also an implementation of the
IPv6 Router Solicitor as specified in
RFC 4861 and
dhcpcd is also an implementation of the
IPv6 Privacy Extensions to AutoConf as specified in
4941. This feature needs to be enabled in the kernel and
dhcpcd will start using it.
dhcpcd is also an implementation of the
DHCPv6 client as specified in
RFC 3315. By default,
dhcpcd only starts DHCPv6 when instructed to do so
by an IPV6 Router Advertisement. If no Identity Association is configured,
then a Non-temporary Address is requested.
Local Link configuration¶If
dhcpcdfailed to obtain a lease, it probes for a valid IPv4LL address (aka ZeroConf, aka APIPA). Once obtained it restarts the process of looking for a DHCP server to get a proper address.
When using IPv4LL,
dhcpcd nearly always
succeeds and returns an exit code of 0. In the rare case it fails, it
normally means that there is a reverse ARP proxy installed which always
defeats IPv4LL probing. To disable this behaviour, you can use the
Multiple interfaces¶If a list of interfaces are given on the command line, then
dhcpcdonly works with those interfaces, otherwise
dhcpcddiscovers available Ethernet interfaces that can be configured. When
dhcpcdis operating on more than one interface, it is called Master mode. and this behaviour can be forced with the
-masteroption so that an individual interface can start
dhcpcdbut only one instance is running. The
dhcpcd-uiproject expects dhcpcd to be running this way.
If a single interface is given then
only works for that interface and runs as a separate instance. The
-waitip option is enabled
in this instance to maintain compatibility with older versions.
Interfaces are preferred by carrier, DHCP lease/IPv4LL and then
lowest metric. For systems that support route metrics, each route will be
tagged with the metric, otherwise
dhcpcd changes the
routes to use the interface with the same route and the lowest metric. See
options below for controlling which interfaces we allow and deny through the
use of patterns.
Hooking into events¶
dhcpcdruns /lib/dhcpcd/dhcpcd-run-hooks, or the script specified by the
-scriptoption. This script runs each script found in /lib/dhcpcd/dhcpcd-hooks in a lexical order. The default installation supplies the scripts 01-test, 02-dump, 20-resolv.conf and 30-hostname. You can disable each script by using the
-nohookoption. See dhcpcd-run-hooks(8) for details on how these scripts work.
dhcpcdcurrently ignores the exit code of the script.
More scripts are supplied in
/usr/share/dhcpcd/hooks and need to be copied to
/lib/dhcpcd/dhcpcd-hooks if you intend to use them.
For example, you could install 10-wpa_supplicant so
dhcpcd can ensure that
wpa_supplicant(8) is always running on a hot-plugged
Fine tuning¶You can fine-tune the behaviour of
dhcpcdwith the following options:
- Background immediately. This is useful for startup scripts which don't disable link messages for carrier status.
- Use this script instead of the default /lib/dhcpcd/dhcpcd-run-hooks.
- Generate an
RFC 4361compliant clientid. This requires persistent storage and not all DHCP servers work with it so it is not enabled by default.
dhcpcdgenerates the DUID and stores it in /etc/dhcpcd.duid. This file should not be copied to other hosts.
- Echo debug messages to the stderr and syslog.
dhcpcdcannot obtain a lease, then try to use the last lease acquired for the interface. If the
-persistentoption is not given then the lease is used if it hasn't expired.
- Push value to the environment for use in
dhcpcd-run-hooks(8). For example, you can force the
hostname hook to always set the hostname with
dhcpcdwill re-apply IP address, routing and run dhcpcd-run-hooks(8) for each interface. This is useful so that a 3rd party such as PPP or VPN can change the routing table and / or DNS, etc and then instruct
dhcpcdto put things back afterwards.
dhcpcddoes not read a new configuration when this happens - you should rebind if you need that functionality.
- Requests that the DHCP server updates DNS using FQDN instead of just a
hostname. Valid values for fqdn are disable, none,
ptr and both.
dhcpcditself never does any DNS updates.
dhcpcdencodes the FQDN hostname as specified in
- Specify a config to load instead of
dhcpcdalways processes the config file before any command line options.
- Sends hostname to the DHCP server so it can be registered in DNS. If hostname is an empty string then the current system hostname is sent. If hostname is a FQDN (ie, contains a .) then it will be encoded as such.
- Send the clientid. If the string is of the format
01:02:03 then it is encoded as hex. For interfaces whose hardware address
is longer than 8 bytes, or if the clientid is an
empty string then
dhcpcdsends a default clientid of the hardware family and the hardware address.
- Override the DHCPv4 vendorclassid field sent. The
dhcpcd-5.5.6:NetBSD-6.99.5:i386:i386If not set then none is sent. Some badly configured DHCP servers reject unknown vendorclassids. To work around it, try and impersonate Windows by using the MSFT vendorclassid.
- Writes to the specified logfile rather than
syslog(3). The logfile is
truncated when opened and is reopened when
- This causes an existing
dhcpcdprocess running on the interface to release its lease and de-configure the interface regardless of the
-persistentoption. If no interface is specified then this applies to all interfaces. If no interfaces are left running,
- Request a specific lease time in seconds. By default
dhcpcddoes not request any lease time and leaves it in the hands of the DHCP server.
dhcpcdin master mode even if only one interface specified on the command line. See the Multiple Interfaces section above.
- Metrics are used to prefer an interface over another one, lowest wins.
dhcpcdwill supply a default metic of 200 + if_nametoindex(3). An extra 100 will be added for wireless interfaces.
dhcpcdto reload its configuration and rebind the specified interface. If no interface is specified then this applies to all interfaces. If
dhcpcdis not running, then it starts up as normal. This may also cause wpa_supplicant(8) to reload its configuration for each interface as well if the relevant hook script has been installed.
dhcpcdto renew existing addresses on the specified interface. If no interface is specified then this applies to all interfaces. If
dhcpcdis not running, then it starts up as normal. Unlike the
-rebindoption above, the configuration for
dhcpcdis not reloaded.
- Request the DHCP option variable for use in /lib/dhcpcd/dhcpcd-run-hooks.
dhcpcdnormally de-configures the interface and configuration when it exits. Sometimes, this isn't desirable if, for example, you have root mounted over NFS or SSH clients connect to this host and they need to be notified of the host shutting down. You can use this option to stop this from happening.
- Request the address in the DHCP DISCOVER message. There is no guarantee this is the address the DHCP server will actually give. If no address is given then the first address currently assigned to the interface is used.
- Behaves like
-requestas above, but sends a DHCP INFORM instead of DISCOVER/REQUEST. This does not get a lease as such, just notifies the DHCP server of the address in use. You should also include the optional cidr network number in case the address is not already configured on the interface.
dhcpcdremains running and pretends it has an infinite lease.
dhcpcdwill not de-configure the interface when it exits. If
dhcpcdfails to contact a DHCP server then it returns a failure instead of falling back on IPv4LL.
- Performs a DHCPv6 Information Request. No address is requested or
specified, but all other DHCPv6 options are allowed. This is normally
performed automatically when the IPv6 Router Advertises that the client
should perform this operation. This option is only needed when
dhcpcdis not processing IPv6RA messages and the need for DHCPv6 Information Request exists.
- Configures a static DHCP value. If you set
dhcpcdwill not attempt to obtain a lease and just use the value for the address with an infinite lease time.
Here is an example which configures a static address, routes and dns.dhcpcd -S ip_address=192.168.0.10/24 \-S routers=192.168.0.1 \-S domain_name_servers=192.168.0.1 \eth0
You cannot presently set static DHCPv6 values. Use the
- Timeout after seconds, instead of the default 30. A
setting of 0 seconds causes
dhcpcdto wait forever to get a lease. If
dhcpcdis working on a single interface then
dhcpcdwill exit when a timeout occurs, otherwise
dhcpcdwill fork into the background.
- Tags the DHCPv4 message with the userclass class. DHCP servers use this to give members of the class DHCP options other than the default, without having to know things like hardware address or hostname.
- Add an encapsulated vendor option. code should be
between 1 and 254 inclusive. To add a raw vendor string, omit
code but keep the comma. Examples.
Set the vendor option 01 with an IP address.dhcpcd -v 01,192.168.0.2 eth0Set the vendor option 02 with a hex code.dhcpcd -v 02,01:02:03:04:05 eth0Set the vendor option 03 with an IP address as a string.dhcpcd -v 03,\"192.168.0.2\" eth0Set un-encapsulated vendor option to hello world.dhcpcd -v ,"hello world" eth0
- Display both program version and copyright information.
dhcpcdthen exits before doing any configuration.
- Wait for an address to be assigned before forking to the background. Does
not take an argument, unlike the below option.
-waitip[4 | 6]
- Wait for an address to be assigned before forking to the background. 4
means wait for an IPv4 address to be assigned. 6 means wait for an IPv6
address to be assigned. If no argument is given,
dhcpcdwill wait for any address protocol to be assigned. It is possible to wait for more than one address protocol and
dhcpcdwill only fork to the background when all waiting conditions are satisfied.
- This will signal an existing
dhcpcdprocess running on the interface to exit. If no interface is specified, then the above is applied to all interfaces. See the
-persistentoption to control configuration persistence on exit, which is enabled by default in dhcpcd.conf(5).
dhcpcdthen waits until this process has exited.
- Allow reboot seconds before moving to the discover
phase if we have an old lease to use. Allow reboot
seconds before starting fallback states from the discover phase. IPv4LL is
started when the first reboot timeout is reached.
The default is 5 seconds. A setting of 0 seconds causes
dhcpcdto skip the reboot phase and go straight into discover. This has no effect on DHCPv6 other than skipping the reboot phase.
dhcpcdwill try to do as much as it can by default. However, there are sometimes situations where you don't want the things to be configured exactly how the the DHCP server wants. Here are some options that deal with turning these bits off.
- Exit after configuring an interface. Use the
-waitipoption to specify which protocol(s) to configure before exiting.
- Configure IPv4 only.
- Configure IPv6 only.
- Don't request or claim the address by ARP. This also disables IPv4LL.
- Don't run in the background when we acquire a lease. This is mainly useful for running under the control of another process, such as a debugger or a network manager.
- Don't run this hook script. Matches full name, or prefixed with 2 numbers
optionally ending with .sh.
So to stop
dhcpcdfrom touching your DNS settings you would do:-dhcpcd -C resolv.conf eth0
- Don't set any default routes.
- Use the last four bytes of the hardware address as the DHCP xid instead of a randomly generated number.
- Instructs the DHCP server to broadcast replies back to the client.
Normally this is only set for non Ethernet interfaces, such as FireWire
and InfiniBand. In most instances,
dhcpcdwill set this automatically.
- Don't receive link messages for carrier status. You should only have to
use this with buggy device drivers or running
dhcpcdthrough a network manager.
- Don't use IPv4LL (aka APIPA, aka Bonjour, aka ZeroConf).
- Removes the option from the DHCP message before processing.
- Print the pidfile
dhcpcdwill use based on commmand-line arguments to stdout.
- Requires the option to be present in all DHCP
messages, otherwise the message is ignored. To enforce that
dhcpcdonly responds to DHCP servers and not BOOTP servers, you can
dhcpcdon the command line, only warnings and errors will be displayed. The messages are still logged though.
- On receipt of DHCP messages just call
/lib/dhcpcd/dhcpcd-run-hooks with the reason of
TEST which echos the DHCP variables found in the message to the console.
The interface configuration isn't touched and neither are any
configuration files. The rapid_commit option is not
sent in TEST mode so that the server does not lease an address. To test
INFORM the interface needs to be configured with the desired address
- Dumps the last lease for the interface to stdout. If
omitted, standard input is used to read a DHCP wire formatted message. Use
-6flags to specify an address family.
- Display a list of option codes, the associated variable and encoding for use in dhcpcd-run-hooks(8). Variables are prefixed with new_ and old_ unless the option number is -. Variables without an option are part of the DHCP message and cannot be directly requested.
- Only accept packets from address[/cidr].
-blacklistis ignored if
- Ignore all packets from address[/cidr].
- When discovering interfaces, the interface name must not match pattern which is a space or comma separated list of patterns passed to fnmatch(3).
- When discovering interfaces, the interface name must match
pattern which is a space or comma separated list of
patterns passed to fnmatch(3). If the same interface is
-denyinterfacesthen it is still denied.
- Don't load any /dev management modules.
3RDPARTY LINK MANAGEMENT¶Some interfaces require configuration by 3rd parties, such as PPP or VPN. When an interface configuration in
dhcpcdis marked as STATIC or INFORM without an address then
dhcpcdwill monitor the interface until an address is added or removed from it and act accordingly. For point to point interfaces (like PPP), a default route to its destination is automatically added to the configuration. If the point to point interface is configured for INFORM, then
dhcpcdunicasts INFORM to the destination, otherwise it defaults to STATIC.
dhcpcdrequires a Berkley Packet Filter, or BPF device on BSD based systems and a Linux Socket Filter, or LPF device on Linux based systems for all IPv4 configuration.
dhcpcd to a single
interface and optionally address family via the command-line then all futher
dhcpcd to rebind, reconfigure or exit need
to include the same restrictive flags so that
knows which process to signal.
- Configuration file for dhcpcd. If you always use the same options, put them here.
- Text file that holds the DUID used to identify the host.
- Text file that holds a secret key known only to the host.
- Bourne shell script that is run to configure or de-configure an interface.
- /dev management modules.
- A directory containing bourne shell scripts that are run by the above
script. Each script can be disabled by using the
-nohookoption described above.
- The actual DHCP message sent by the server. We use this when reading the last lease and use the files mtime as when it was issued.
- The actual DHCPv6 message sent by the server. We use this when reading the last lease and use the files mtime as when it was issued.
- Stores the monotonic counter used in the replay field in Authentication Options.
- Stores the PID of
dhcpcdrunning on all interfaces.
- Stores the PID of
dhcpcdrunning on the interface.
- Control socket to the master daemon.
- Unpriviledged socket to the master daemon, only allows state retrieval.
- Control socket to per interface daemon.
SEE ALSO¶fnmatch(3), if_nametoindex(3), dhcpcd.conf(5), resolv.conf(5), dhcpcd-run-hooks(8), resolvconf(8)
STANDARDS¶RFC 951, RFC 1534, RFC 2104, RFC 2131, RFC 2132, RFC 2563, RFC 2855, RFC 3004, RFC 3118, RFC 3203, RFC 3315, RFC 3361, RFC 3633, RFC 3396, RFC 3397, RFC 3442, RFC 3495, RFC 3925, RFC 3927, RFC 4039, RFC 4075, RFC 4242, RFC 4361, RFC 4390, RFC 4702, RFC 4074, RFC 4861, RFC 4833, RFC 4941, RFC 5227, RFC 5942, RFC 5969, RFC 6106, RFC 6334, RFC 6603, RFC 6704, RFC 7217, RFC 7550.
AUTHORS¶Roy Marples <firstname.lastname@example.org>
BUGS¶Please report them to http://roy.marples.name/projects/dhcpcd
|January 14, 2016||Linux 4.9.0-9-amd64|