Scroll to navigation

UFTDI(4) Device Drivers Manual UFTDI(4)

NAME

uftdi
USB support for serial adapters based on the FTDI family of USB serial adapter chips.

SYNOPSIS

To compile this driver into the kernel, place the following lines in your kernel configuration file:
device usb
device ucom
device uftdi
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
uftdi_load="YES"

DESCRIPTION

The uftdi driver provides support for various serial adapters based on the following FTDI chips:
  • FT8U100AX
  • FT8U232AM
  • FT8U232BM
  • FT232R
  • FT2232C
  • FT2232D
  • FT2232H
  • FT4232H
  • FT230X
The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
Many of the supported chips provide additional functionality such as bitbang mode and the MPSSE engine for serial bus emulation. The uftdi driver provides access to that functionality with the following ioctl(2) calls, defined in <dev/usb/uftdiio.h>:
(int)
Reset the channel to its default configuration, flush RX and TX FIFOs.
(int)
Flush the RX FIFO.
(int)
Flush the TX FIFO.
(struct uftdi_bitmode)
Put the channel into the operating mode specified in mode, and set the pins indicated by ones in iomask to output mode. The mode must be one of the uftdi_bitmodes values.
enum uftdi_bitmodes 
{ 
	UFTDI_BITMODE_ASYNC = 0, 
	UFTDI_BITMODE_MPSSE = 1, 
	UFTDI_BITMODE_SYNC = 2, 
	UFTDI_BITMODE_CPU_EMUL = 3, 
	UFTDI_BITMODE_FAST_SERIAL = 4, 
	UFTDI_BITMODE_CBUS = 5, 
	UFTDI_BITMODE_NONE = 0xff, 
}; 
 
struct uftdi_bitmode 
{ 
	uint8_t mode; 
	uint8_t iomask; 
};
    
Manuals and application notes published by FTDI describe these modes in detail. To use most of these modes, you first put the channel into the desired mode, then you read(2) and write(2) data which either reflects pin state or is interpreted as MPSSE commands and parameters, depending on the mode.
(struct uftdi_bitmode)
Return the state of the bitbang pins at the time of the call in the iomask member. The mode member is unused.
(int)
Set the character which is inserted into the buffer to mark the point of an error such as FIFO overflow.
(int)
Set the character which causes a partial FIFO full of data to be returned immediately even if the FIFO is not full.
(int)
Set the amount of time to wait for a full FIFO, in milliseconds. If more than this much time elapses without receiving a new character, any characters in the FIFO are returned.
(int)
Get the current value of the latency timer.
(int)
Get the hardware revision number. This is the bcdDevice value from the usb_device_descriptor.

HARDWARE

The uftdi driver supports the following adapters:
  • B&B Electronics USB->RS422/485 adapter
  • Elexol USB MOD1 and USB MOD3
  • HP USB-Serial adapter shipped with some HP laptops
  • Inland UAS111
  • QVS USC-1000
  • Buffalo PC-OP-RS / Kurouto-shikou KURO-RS universal remote
  • Prologix GPIB-USB Controller

SEE ALSO

tty(4), ucom(4), usb(4)

HISTORY

The uftdi driver appeared in FreeBSD 4.8 from NetBSD 1.5.
March 31, 2014 Debian