|UDBP(4)||Device Drivers Manual||UDBP(4)|
USB Double Bulk Pipe driver
SYNOPSIS¶To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
udbpdriver provides support for host-to-host cables that contain at least two bulk pipes (one for each direction), for example the EzLink cable and the NetChip 1080 chip. It requires netgraph(4) to be available. This can be done either by adding
options NETGRAPHto your kernel configuration file, or alternatively loading netgraph(4) as a module, either from /boot/loader.conf or from the command line, before the
udbpdriver to the kernel.
Load the netgraph(4) module and then the
ngctl mkpeer udbp0: iface data inet
Create a new network interface node and connect its inet hook to the data hook of the
ifconfig ng0 10.0.0.1 10.0.0.2
udbpnode. ifconfig(8) configures the resulting network interface ng0 with a local IP address of 10.0.0.1 and a remote IP address of 10.0.0.2. On the remote host, the two IP addresses should of course be reversed.
SEE ALSO¶netgraph(4), ng_iface(4), ohci(4), uhci(4), usb(4), ngctl(8)
udbpdriver first appeared in FreeBSD 5.0.
udbpdriver was written by Doug Ambrisko ⟨firstname.lastname@example.org⟩, Julian Elischer ⟨julian@FreeBSD.org⟩ and Nick Hibma ⟨n_hibma@FreeBSD.org⟩. This manual page was written by Nick Hibma ⟨n_hibma@FreeBSD.org⟩.
|November 22, 2006||Debian|