|STG(4)||Device Drivers Manual||STG(4)|
driver for Future Domain based SCSI controllers
SYNOPSIS¶To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
device stgFor one or more ISA cards:
device isaIn /boot/device.hints:
hint.stg.0.at="isa"For one or more PCI cards:
stgdriver provides support for ISA, PCCARD and PCI controllers based on Future Domain SCSI controller chips including the TMC-16C30, 16C50 and 32C60.
HARDWARE¶Controllers supported by the
- Adaptec 2920/A
- Future Domain SCSI2GO
- Future Domain TMC-18XX/3260
- IBM SCSI PCMCIA Card
- ICM PSC-2401 SCSI
- MELCO IFC-SC
- RATOC REX-5536, REX-5536AM, REX-5536M, REX-9836A
SEE ALSO¶ahc(4), cd(4), ch(4), da(4), intro(4), sa(4), scsi(4)
stgdevice driver has been developed for NetBSD/pc98 and ported for FreeBSD. It first appeared in FreeBSD 2.2 with PAO and merged in FreeBSD 4.2.
stgdriver was written by Naofumi HONDA.
|August 8, 2004||Debian|