.TH "ROFF" "7" "September 24, 2015" "Debian" "Miscellaneous Information Manual" .nh .if n .ad l .SH "NAME" \fBroff\fR \- roff language reference for mandoc .SH "DESCRIPTION" The \fBroff\fR language is a general purpose text formatting language. Since traditional implementations of the mdoc(7) and man(7) manual formatting languages are based on it, many real-world manuals use small numbers of \fBroff\fR requests and escape sequences intermixed with their mdoc(7) or man(7) code. To properly format such manuals, the mandoc(1) utility supports a tiny subset of \fBroff\fR requests and escapes. Only these requests and escapes supported by mandoc(1) are documented in the present manual, together with the basic language syntax shared by \fBroff\fR, mdoc(7), and man(7). For complete \fBroff\fR manuals, consult the \fISEE ALSO\fR section. .PP Input lines beginning with the control character \(oq\&.\(cq are parsed for requests and macros. Such lines are called \(Lqrequest lines\(Rq or \(Lqmacro lines\(Rq, respectively. Requests change the processing state and manipulate the formatting; some macros also define the document structure and produce formatted output. The single quote ("\(aq") is accepted as an alternative control character, treated by mandoc(1) just like \(oq\&.\(cq .PP Lines not beginning with control characters are called \(Lqtext lines\(Rq. They provide free-form text to be printed; the formatting of the text depends on the respective processing context. .SH "LANGUAGE SYNTAX" \fBroff\fR documents may contain only graphable 7-bit ASCII characters, the space character, and, in certain circumstances, the tab character. The backslash character \(oq\e\(cq indicates the start of an escape sequence, used for example for \fIComments\fR, \fISpecial Characters\fR, \fIPredefined Strings\fR, and user-defined strings defined using the \fIds\fR request. For a listing of escape sequences, consult the \fIESCAPE SEQUENCE REFERENCE\fR below. .SS "Comments" Text following an escaped double-quote \(oq\e\(dq\(cq, whether in a request, macro, or text line, is ignored to the end of the line. A request line beginning with a control character and comment escape \(oq\&.\e\(dq\(cq is also ignored. Furthermore, request lines with only a control character and optional trailing whitespace are stripped from input. .PP Examples: .nf .RS 6n \&.\e\(dq This is a comment line. \&.\e\(dq The next line is ignored: \&. \&.Sh EXAMPLES \e\(dq This is a comment, too. \&example text \e\(dq And so is this. .RE .fi .SS "Special Characters" Special characters are used to encode special glyphs and are rendered differently across output media. They may occur in request, macro, and text lines. Sequences begin with the escape character \(oq\e\(cq followed by either an open-parenthesis \(oq\&(\(cq for two-character sequences; an open-bracket \(oq\&[\(cq for n-character sequences (terminated at a close-bracket \(oq\&]\(cq); or a single one character sequence. .PP Examples: .RS 6n .PD 0 .TP 8n \fR\e(em\fR Two-letter em dash escape. .TP 8n \fR\ee\fR One-letter backslash escape. .RE .PD .PP See mandoc_char(7) for a complete list. .SS "Text Decoration" Terms may be text-decorated using the \(oq\ef\(cq escape followed by an indicator: B (bold), I (italic), R (regular), or P (revert to previous mode). A numerical representation 3, 2, or 1 (bold, italic, and regular, respectively) may be used instead. The indicator or numerical representative may be preceded by C (constant-width), which is ignored. .PP The two-character indicator \(oqBI\(cq requests a font that is both bold and italic. It may not be portable to old roff implementations. .PP Examples: .RS 6n .PD 0 .TP 8n \fR\efBbold\efR\fR Write in \fBbold\fP, then switch to regular font mode. .TP 8n \fR\efIitalic\efP\fR Write in \fIitalic\fP, then return to previous font mode. .TP 8n \fR\ef(BIbold italic\efP\fR Write in \f(BIbold italic\fP, then return to previous font mode. .RE .PD .PP Text decoration is \fInot\fR recommended for mdoc(7), which encourages semantic annotation. .SS "Predefined Strings" Predefined strings, like \fISpecial Characters\fR, mark special output glyphs. Predefined strings are escaped with the slash-asterisk, \(oq\e*\(cq: single-character \(oq\e*X\(cq, two-character \(oq\e*(XX\(cq, and N-character \(oq\e*[N]\(cq. .PP Examples: .RS 6n .PD 0 .TP 8n \fR\e*(Am\fR Two-letter ampersand predefined string. .TP 8n \fR\e*q\fR One-letter double-quote predefined string. .RE .PD .PP Predefined strings are not recommended for use, as they differ across implementations. Those supported by mandoc(1) are listed in mandoc_char(7). Manuals using these predefined strings are almost certainly not portable. .SS "Whitespace" Whitespace consists of the space character. In text lines, whitespace is preserved within a line. In request and macro lines, whitespace delimits arguments and is discarded. .PP Unescaped trailing spaces are stripped from text line input unless in a literal context. In general, trailing whitespace on any input line is discouraged for reasons of portability. In the rare case that a blank character is needed at the end of an input line, it may be forced by \(oq\e\ \e&\(cq. .PP Literal space characters can be produced in the output using escape sequences. In macro lines, they can also be included in arguments using quotation; see \fIMACRO SYNTAX\fR for details. .PP Blank text lines, which may include whitespace, are only permitted within literal contexts. If the first character of a text line is a space, that line is printed with a leading newline. .SS "Scaling Widths" Many requests and macros support scaled widths for their arguments. The syntax for a scaled width is \(oq\fR[+-]?[0-9]*.[0-9]*[:unit:]\fR\(cq, where a decimal must be preceded or followed by at least one digit. Negative numbers, while accepted, are truncated to zero. .PP The following scaling units are accepted: .PP .RS 6n .PD 0 .TP 8n c centimetre .TP 8n i inch .TP 8n P pica (~1/6 inch) .TP 8n p point (~1/72 inch) .TP 8n f scale \(oqu\(cq by 65536 .TP 8n v default vertical span .TP 8n m width of rendered \(oqm\(cq (em) character .TP 8n n width of rendered \(oqn\(cq (en) character .TP 8n u default horizontal span for the terminal .TP 8n M mini-em (~1/100 em) .RE .PD .PP Using anything other than \(oqm\(cq, \(oqn\(cq, or \(oqv\(cq is necessarily non-portable across output media. See \fICOMPATIBILITY\fR. .PP If a scaling unit is not provided, the numerical value is interpreted under the default rules of \(oqv\(cq for vertical spaces and \(oqu\(cq for horizontal ones. .PP Examples: .RS 6n .PD 0 .TP 20n \fR\&.Bl -tag -width 2i\fR two-inch tagged list indentation in mdoc(7) .TP 20n \fR\&.HP 2i\fR two-inch tagged list indentation in man(7) .TP 20n \fR\&.sp 2v\fR two vertical spaces .RE .PD .SS "Sentence Spacing" Each sentence should terminate at the end of an input line. By doing this, a formatter will be able to apply the proper amount of spacing after the end of sentence (unescaped) period, exclamation mark, or question mark followed by zero or more non-sentence closing delimiters (\(oq\&)\(cq, \(oq\&]\(cq, \(oq\&'\(cq, \(oq\&"\(cq) \&. .PP The proper spacing is also intelligently preserved if a sentence ends at the boundary of a macro line. .PP Examples: .nf .RS 6n Do not end sentences mid-line like this. Instead, end a sentence like this. A macro would end like this: \&.Xr mandoc 1 \&. .RE .fi .SH "REQUEST SYNTAX" A request or macro line consists of: .TP 5n 1.\& the control character \(oq\&.\(cq or \(oq\(aq\(cq at the beginning of the line, .PD 0 .TP 5n 2.\& optionally an arbitrary amount of whitespace, .TP 5n 3.\& the name of the request or the macro, which is one word of arbitrary length, terminated by whitespace, .TP 5n 4.\& and zero or more arguments delimited by whitespace. .PD .PP Thus, the following request lines are all equivalent: .nf .sp .RS 6n \&.ig end \&.ig end \&. ig end .RE .fi .SH "MACRO SYNTAX" Macros are provided by the mdoc(7) and man(7) languages and can be defined by the \fI\&de\fR request. When called, they follow the same syntax as requests, except that macro arguments may optionally be quoted by enclosing them in double quote characters (\(oq\(dq\(cq). Quoted text, even if it contains whitespace or would cause a macro invocation when unquoted, is always considered literal text. Inside quoted text, pairs of double quote characters (\(oq""\(cq) resolve to single double quote characters. .PP To be recognised as the beginning of a quoted argument, the opening quote character must be preceded by a space character. A quoted argument extends to the next double quote character that is not part of a pair, or to the end of the input line, whichever comes earlier. Leaving out the terminating double quote character at the end of the line is discouraged. For clarity, if more arguments follow on the same input line, it is recommended to follow the terminating double quote character by a space character; in case the next character after the terminating double quote character is anything else, it is regarded as the beginning of the next, unquoted argument. .PP Both in quoted and unquoted arguments, pairs of backslashes (\(oq\e\e\(cq) resolve to single backslashes. In unquoted arguments, space characters can alternatively be included by preceding them with a backslash (\(oq\e\~\(cq), but quoting is usually better for clarity. .PP Examples: .RS 6n .PD 0 .TP 8n \fR.Fn strlen \(dqconst char *s\(dq\fR Group arguments "const char *s" into one function argument. If unspecified, "const", "char", and "*s" would be considered separate arguments. .TP 8n \fR.Op \(dqFl a\(dq\fR Consider "\&Fl a" as literal text instead of a flag macro. .RE .PD .SH "REQUEST REFERENCE" The mandoc(1) \fBroff\fR parser recognises the following requests. For requests marked as "ignored" or "unsupported", any arguments are ignored, and the number of arguments is not checked. .SS "\&ab" Abort processing. Currently unsupported. .SS "\&ad" Set line adjustment mode. It takes one argument to select normal, left, right, or center adjustment for subsequent text. Currently ignored. .SS "\&af" Assign an output format to a number register. Currently ignored. .SS "\&aln" Create an alias for a number register. Currently unsupported. .SS "\&als" Create an alias for a request, string, macro, or diversion. Currently unsupported. .SS "\&am" Append to a macro definition. The syntax of this request is the same as that of \fI\&de\fR. .SS "\&am1" Append to a macro definition, switching roff compatibility mode off during macro execution (groff extension). The syntax of this request is the same as that of \fI\&de1\fR. Since mandoc(1) does not implement \fBroff\fR compatibility mode at all, it handles this request as an alias for \fI\&am\fR. .SS "\&ami" Append to a macro definition, specifying the macro name indirectly (groff extension). The syntax of this request is the same as that of \fI\&dei\fR. .SS "\&ami1" Append to a macro definition, specifying the macro name indirectly and switching roff compatibility mode off during macro execution (groff extension). The syntax of this request is the same as that of \fI\&dei1\fR. Since mandoc(1) does not implement \fBroff\fR compatibility mode at all, it handles this request as an alias for \fI\&ami\fR. .SS "\&as" Append to a user-defined string. The syntax of this request is the same as that of \fI\&ds\fR. If a user-defined string with the specified name does not yet exist, it is set to the empty string before appending. .SS "\&as1" Append to a user-defined string, switching roff compatibility mode off during macro execution (groff extension). The syntax of this request is the same as that of \fI\&ds1\fR. Since mandoc(1) does not implement \fBroff\fR compatibility mode at all, it handles this request as an alias for \fI\&as\fR. .SS "\&asciify" Fully unformat a diversion. Currently unsupported. .SS "\&backtrace" Print a backtrace of the input stack. This is a groff extension and currently ignored. .SS "\&bd" Artificially embolden by repeated printing with small shifts. Currently ignored. .SS "\&bleedat" Set the BleedBox page parameter for PDF generation. This is a Heirloom extension and currently ignored. .SS "\&blm" Set a blank line trap. Currently unsupported. .SS "\&box" Begin a diversion without including a partially filled line. Currently unsupported. .SS "\&boxa" Add to a diversion without including a partially filled line. Currently unsupported. .SS "\&bp" Begin new page. Currently ignored. .SS "\&BP" Define a frame and place a picture in it. This is a Heirloom extension and currently unsupported. .SS "\&br" Break the output line. See man(7) and mdoc(7). .SS "\&break" Break out of a \fI\&while\fR loop. Currently unsupported. .SS "\&breakchar" Optional line break characters. This is a Heirloom extension and currently ignored. .SS "\&brnl" Break output line after next N input lines. This is a Heirloom extension and currently ignored. .SS "\&brp" Break and spread output line. Currently, this is implemented as an alias for \fI\&br\fR. .SS "\&brpnl" Break and spread output line after next N input lines. This is a Heirloom extension and currently ignored. .SS "\&c2" Change the no-break control character. Currently unsupported. .SS "\&cc" Change the control character. Its syntax is as follows: .nf .sp .RS 6n \&.\fB\&cc\fR [\fIc\fR] .RE .fi .PP If \fIc\fR is not specified, the control character is reset to \(oq\&.\(cq. Trailing characters are ignored. .SS "\&ce" Center some lines. It takes one integer argument, specifying how many lines to center. Currently ignored. .SS "\&cf" Output the contents of a file. Ignored because insecure. .SS "\&cflags" Set character flags. This is a groff extension and currently ignored. .SS "\&ch" Change a trap location. Currently ignored. .SS "\&char" Define a new glyph. Currently unsupported. .SS "\&chop" Remove the last character from a macro, string, or diversion. Currently unsupported. .SS "\&class" Define a character class. This is a groff extension and currently ignored. .SS "\&close" Close an open file. Ignored because insecure. .SS "\&CL" Print text in color. This is a Heirloom extension and currently unsupported. .SS "\&color" Activate or deactivate colors. This is a groff extension and currently ignored. .SS "\&composite" Define a name component for composite glyph names. This is a groff extension and currently unsupported. .SS "\&continue" Immediately start the next iteration of a \fI\&while\fR loop. Currently unsupported. .SS "\&cp" Switch \fBroff\fR compatibility mode on or off. Currently ignored. .SS "\&cropat" Set the CropBox page parameter for PDF generation. This is a Heirloom extension and currently ignored. .SS "\&cs" Constant character spacing mode. Currently ignored. .SS "\&cu" Underline including whitespace. Currently ignored. .SS "\&da" Append to a diversion. Currently unsupported. .SS "\&dch" Change a trap location in the current diversion. This is a Heirloom extension and currently unsupported. .SS "\&de" Define a \fBroff\fR macro. Its syntax can be either .nf .sp .RS 6n \&.\fB\&de\fR \fIname\fR \fImacro definition\fR \&.. .RE .fi .PP or .nf .sp .RS 6n \&.\fB\&de\fR \fIname\fR \fIend\fR \fImacro definition\fR \&.\fIend\fR .RE .fi .PP Both forms define or redefine the macro \fIname\fR to represent the \fImacro definition\fR, which may consist of one or more input lines, including the newline characters terminating each line, optionally containing calls to \fBroff\fR requests, \fBroff\fR macros or high-level macros like man(7) or mdoc(7) macros, whichever applies to the document in question. .PP Specifying a custom \fIend\fR macro works in the same way as for \fI\&ig\fR; namely, the call to \(oq.\fIend\fR\(cq first ends the \fImacro definition\fR, and after that, it is also evaluated as a \fBroff\fR request or \fBroff\fR macro, but not as a high-level macro. .PP The macro can be invoked later using the syntax .PP .RS 6n \&.\fIname\fR [\fIargument\fR [\fIargument ...\fR]] .RE .PP Regarding argument parsing, see \fIMACRO SYNTAX\fR above. .PP The line invoking the macro will be replaced in the input stream by the \fImacro definition\fR, replacing all occurrences of \e\e$\fIN\fR, where \fIN\fR is a digit, by the \fIN\fRth \fIargument\fR. For example, .nf .sp .RS 6n \&.de ZN \efI\e^\e\e$1\e^\efP\e\e$2 \&.. \&.ZN XtFree . .RE .fi .PP produces .PP .RS 6n \efI\e^XtFree\e^\efP. .RE .PP in the input stream, and thus in the output: \fI\^XtFree\^\fP. Each occurrence of \e\e$* is replaced with all the arguments, joined together with single blank characters. .PP Since macros and user-defined strings share a common string table, defining a macro \fIname\fR clobbers the user-defined string \fIname\fR, and the \fImacro definition\fR can also be printed using the \(oq\e*\(cq string interpolation syntax described below \fIds\fR, but this is rarely useful because every macro definition contains at least one explicit newline character. .PP In order to prevent endless recursion, both groff and mandoc(1) limit the stack depth for expanding macros and strings to a large, but finite number, and mandoc(1) also limits the length of the expanded input line. Do not rely on the exact values of these limits. .SS "\&de1" Define a \fBroff\fR macro that will be executed with \fBroff\fR compatibility mode switched off during macro execution. This is a groff extension. Since mandoc(1) does not implement \fBroff\fR compatibility mode at all, it handles this request as an alias for \fI\&de\fR. .SS "\&defcolor" Define a color name. This is a groff extension and currently ignored. .SS "\&dei" Define a \fBroff\fR macro, specifying the macro name indirectly (groff extension). The syntax of this request is the same as that of \fI\&de\fR. The request .PP .RS 6n \&.\fB\&dei\fR \fIname\fR [\fIend\fR] .RE .PP has the same effect as: .PP .RS 6n \&.\fB\&de\fR \e*[\fIname\fR] [\e*[\fIend\fR]] .RE .SS "\&dei1" Define a \fBroff\fR macro that will be executed with \fBroff\fR compatibility mode switched off during macro execution, specifying the macro name indirectly (groff extension). Since mandoc(1) does not implement \fBroff\fR compatibility mode at all, it handles this request as an alias for \fI\&dei\fR. .SS "\&device" This request only makes sense with the groff-specific intermediate output format and is unsupported. .SS "\&devicem" This request only makes sense with the groff-specific intermediate output format and is unsupported. .SS "\&di" Begin a diversion. Currently unsupported. .SS "\&do" Execute \fBroff\fR request or macro line with compatibility mode disabled. Currently unsupported. .SS "\&ds" Define a user-defined string. Its syntax is as follows: .PP .RS 6n \&.\fB\&ds\fR \fIname\fR [\(dq]\fIstring\fR .RE .PP The \fIname\fR and \fIstring\fR arguments are space-separated. If the \fIstring\fR begins with a double-quote character, that character will not be part of the string. All remaining characters on the input line form the \fIstring\fR, including whitespace and double-quote characters, even trailing ones. .PP The \fIstring\fR can be interpolated into subsequent text by using \e*[\fIname\fR] for a \fIname\fR of arbitrary length, or \e*(NN or \e*N if the length of \fIname\fR is two or one characters, respectively. Interpolation can be prevented by escaping the leading backslash; that is, an asterisk preceded by an even number of backslashes does not trigger string interpolation. .PP Since user-defined strings and macros share a common string table, defining a string \fIname\fR clobbers the macro \fIname\fR, and the \fIname\fR used for defining a string can also be invoked as a macro, in which case the following input line will be appended to the \fIstring\fR, forming a new input line passed to the \fBroff\fR parser. For example, .nf .sp .RS 6n \&.ds badidea .S \&.badidea H SYNOPSIS .RE .fi .PP invokes the \fBSH\fR macro when used in a man(7) document. Such abuse is of course strongly discouraged. .SS "\&ds1" Define a user-defined string that will be expanded with \fBroff\fR compatibility mode switched off during string expansion. This is a groff extension. Since mandoc(1) does not implement \fBroff\fR compatibility mode at all, it handles this request as an alias for \fI\&ds\fR. .SS "\&dwh" Set a location trap in the current diversion. This is a Heirloom extension and currently unsupported. .SS "\&dt" Set a trap within a diversion. Currently unsupported. .SS "\&ec" Change the escape character. Currently unsupported. .SS "\&ecs" Restore the escape character. Currently unsupported. .SS "\&ecr" Save the escape character. Currently unsupported. .SS "\&el" The "else" half of an if/else conditional. Pops a result off the stack of conditional evaluations pushed by \fI\&ie\fR and uses it as its conditional. If no stack entries are present (e.g., due to no prior \fI\&ie\fR calls) then false is assumed. The syntax of this request is similar to \fI\&if\fR except that the conditional is missing. .SS "\&em" Set a trap at the end of input. Currently unsupported. .SS "\&EN" End an equation block. See \fI\&EQ\fR. .SS "\&eo" Disable the escape mechanism completely. Currently unsupported. .SS "\&EP" End a picture started by \fI\&BP\fR. This is a Heirloom extension and currently unsupported. .SS "\&EQ" Begin an equation block. See eqn(7) for a description of the equation language. .SS "\&errprint" Print a string like an error message. This is a Heirloom extension and currently ignored. .SS "\&ev" Switch to another environment. Currently unsupported. .SS "\&evc" Copy an environment into the current environment. Currently unsupported. .SS "\&ex" Abort processing and exit. Currently unsupported. .SS "\&fallback" Select the fallback sequence for a font. This is a Heirloom extension and currently ignored. .SS "\&fam" Change the font family. Takes one argument specifying the font family to be selected. It is a groff extension and currently ignored. .SS "\&fc" Define a delimiting and a padding character for fields. Currently unsupported. .SS "\&fchar" Define a fallback glyph. Currently unsupported. .SS "\&fcolor" Set the fill color for \eD objects. This is a groff extension and currently ignored. .SS "\&fdeferlig" Defer ligature building. This is a Heirloom extension and currently ignored. .SS "\&feature" Enable or disable an OpenType feature. This is a Heirloom extension and currently ignored. .SS "\&fi" Switch to fill mode. See man(7). Ignored in mdoc(7). .SS "\&fkern" Control the use of kerning tables for a font. This is a Heirloom extension and currently ignored. .SS "\&fl" Flush output. Currently ignored. .SS "\&flig" Define ligatures. This is a Heirloom extension and currently ignored. .SS "\&fp" Assign font position. Currently ignored. .SS "\&fps" Mount a font with a special character map. This is a Heirloom extension and currently ignored. .SS "\&fschar" Define a font-specific fallback glyph. This is a groff extension and currently unsupported. .SS "\&fspacewidth" Set a font-specific width for the space character. This is a Heirloom extension and currently ignored. .SS "\&fspecial" Conditionally define a special font. This is a groff extension and currently ignored. .SS "\&ft" Change the font. Its syntax is as follows: .PP .RS 6n \&.\fB\&ft\fR [\fIfont\fR] .RE .PP The following \fIfont\fR arguments are supported: .RS 6n .TP 6n \fBB\fR, \fBBI\fR, \fB3\fR, \fB4\fR switches to \fBbold\fR font .TP 6n \fBI\fR, \fB2\fR switches to \fIunderlined\fR font .TP 6n \fBR\fR, \fBCW\fR, \fB1\fR switches to normal font .TP 6n \fBP\fR or no argument switches back to the previous font .RE .PP This request takes effect only locally, may be overridden by macros and escape sequences, and is only supported in man(7) for now. .SS "\&ftr" Translate font name. This is a groff extension and currently ignored. .SS "\&fzoom" Zoom font size. Currently ignored. .SS "\&gcolor" Set glyph color. This is a groff extension and currently ignored. .SS "\&hc" Set the hyphenation character. Currently ignored. .SS "\&hcode" Set hyphenation codes of characters. Currently ignored. .SS "\&hidechar" Hide characters in a font. This is a Heirloom extension and currently ignored. .SS "\&hla" Set hyphenation language. This is a groff extension and currently ignored. .SS "\&hlm" Set maximum number of consecutive hyphenated lines. Currently ignored. .SS "\&hpf" Load hyphenation pattern file. This is a groff extension and currently ignored. .SS "\&hpfa" Load hyphenation pattern file, appending to the current patterns. This is a groff extension and currently ignored. .SS "\&hpfcode" Define mapping values for character codes in hyphenation patterns. This is a groff extension and currently ignored. .SS "\&hw" Specify hyphenation points in words. Currently ignored. .SS "\&hy" Set automatic hyphenation mode. Currently ignored. .SS "\&hylang" Set hyphenation language. This is a Heirloom extension and currently ignored. .SS "\&hylen" Minimum word length for hyphenation. This is a Heirloom extension and currently ignored. .SS "\&hym" Set hyphenation margin. This is a groff extension and currently ignored. .SS "\&hypp" Define hyphenation penalties. This is a Heirloom extension and currently ignored. .SS "\&hys" Set hyphenation space. This is a groff extension and currently ignored. .SS "\&ie" The "if" half of an if/else conditional. The result of the conditional is pushed into a stack used by subsequent invocations of \fI\&el\fR, which may be separated by any intervening input (or not exist at all). Its syntax is equivalent to \fI\&if\fR. .SS "\&if" Begins a conditional. This request has the following syntax: .nf .sp .RS 6n \&.if COND BODY .RE .fi .nf .sp .RS 6n \&.if COND \e{BODY BODY...\e} .RE .fi .nf .sp .RS 6n \&.if COND \e{\e BODY... \&.\e} .RE .fi .PP COND is a conditional statement. Currently, mandoc(1) supports the following subset of roff conditionals: .TP 4n \fB\(bu\fR If \(oq\&!\(cq is prefixed to COND, the condition is logically inverted. .TP 4n \fB\(bu\fR If the first character of COND is \(oqn\(cq (nroff mode) or \(oqo\(cq (odd page), COND evaluates to true. .TP 4n \fB\(bu\fR If the first character of COND is \(oqc\(cq (character available), \(oqd\(cq (string defined), \(oqe\(cq (even page), \(oqt\(cq (troff mode), or \(oqv\(cq (vroff mode), COND evaluates to false. .TP 4n \fB\(bu\fR If the first character of COND is \(oqr\(cq, it evaluates to true if the rest of COND is the name of an existing number register; otherwise, it evaluates to false. .TP 4n \fB\(bu\fR If COND starts with a parenthesis or with an optionally signed integer number, it is evaluated according to the rules of \fINumerical expressions\fR explained below. It evaluates to true if the result is positive, or to false if the result is zero or negative. .TP 4n \fB\(bu\fR Otherwise, the first character of COND is regarded as a delimiter and COND evaluates to true if the string extending from its first to its second occurrence is equal to the string extending from its second to its third occurrence. .TP 4n \fB\(bu\fR If COND cannot be parsed, it evaluates to false. .PP If a conditional is false, its children are not processed, but are syntactically interpreted to preserve the integrity of the input document. Thus, .PP .RS 6n \&.if t .ig .RE .PP will discard the \(oq\&.ig\(cq, which may lead to interesting results, but .PP .RS 6n \&.if t .if t \e{\e .RE .PP will continue to syntactically interpret to the block close of the final conditional. Sub-conditionals, in this case, obviously inherit the truth value of the parent. .PP If the BODY section is begun by an escaped brace \(oq\e{\(cq, scope continues until the end of the input line containing the matching closing-brace escape sequence \(oq\e}\(cq. If the BODY is not enclosed in braces, scope continues until the end of the line. If the COND is followed by a BODY on the same line, whether after a brace or not, then requests and macros \fImust\fR begin with a control character. It is generally more intuitive, in this case, to write .nf .sp .RS 6n \&.if COND \e{\e \&.foo bar \&.\e} .RE .fi .PP than having the request or macro follow as .PP .RS 6n \&.if COND \e{ .foo .RE .PP The scope of a conditional is always parsed, but only executed if the conditional evaluates to true. .PP Note that the \(oq\e}\(cq is converted into a zero-width escape sequence if not passed as a standalone macro \(oq\&.\e}\(cq. For example, .PP .RS 6n \&.Fl a \e} b .RE .PP will result in \(oq\e}\(cq being considered an argument of the \(oq\&Fl\(cq macro. .SS "\&ig" Ignore input. Its syntax can be either .nf .sp .RS 6n \&.\fB\&ig\fR \fIignored text\fR \&.. .RE .fi .PP or .nf .sp .RS 6n \&.\fB\&ig\fR \fIend\fR \fIignored text\fR \&.\fIend\fR .RE .fi .PP In the first case, input is ignored until a \(oq\&..\(cq request is encountered on its own line. In the second case, input is ignored until the specified \(oq.\fIend\fR\(cq macro is encountered. Do not use the escape character \(oq\e\(cq anywhere in the definition of \fIend\fR; it would cause very strange behaviour. .PP When the \fIend\fR macro is a roff request or a roff macro, like in .PP .RS 6n \&.ig if .RE .PP the subsequent invocation of \fI\&if\fR will first terminate the \fIignored text\fR, then be invoked as usual. Otherwise, it only terminates the \fIignored text\fR, and arguments following it or the \(oq\&..\(cq request are discarded. .SS "\&in" Change indentation. See man(7). Ignored in mdoc(7). .SS "\&index" Find a substring in a string. This is a Heirloom extension and currently unsupported. .SS "\&it" Set an input line trap. Its syntax is as follows: .PP .RS 6n \&.\fBit\fR \fIexpression macro\fR .RE .PP The named \fImacro\fR will be invoked after processing the number of input text lines specified by the numerical \fIexpression\fR. While evaluating the \fIexpression\fR, the unit suffixes described below \fIScaling Widths\fR are ignored. .SS "\&itc" Set an input line trap, not counting lines ending with \ec. Currently unsupported. .SS "\&IX" To support the generation of a table of contents, pod2man(1) emits this user-defined macro, usually without defining it. To avoid reporting large numbers of spurious errors, mandoc(1) ignores it. .SS "\&kern" Switch kerning on or off. Currently ignored. .SS "\&kernafter" Increase kerning after some characters. This is a Heirloom extension and currently ignored. .SS "\&kernbefore" Increase kerning before some characters. This is a Heirloom extension and currently ignored. .SS "\&kernpair" Add a kerning pair to the kerning table. This is a Heirloom extension and currently ignored. .SS "\&lc" Define a leader repetition character. Currently unsupported. .SS "\&lc_ctype" Set the \fRLC_CTYPE\fR locale. This is a Heirloom extension and currently unsupported. .SS "\&lds" Define a local string. This is a Heirloom extension and currently unsupported. .SS "\&length" Count the number of input characters in a user-defined string. Currently unsupported. .SS "\&letadj" Dynamic letter spacing and reshaping. This is a Heirloom extension and currently ignored. .SS "\&lf" Change the line number for error messages. Ignored because insecure. .SS "\&lg" Switch the ligature mechanism on or off. Currently ignored. .SS "\&lhang" Hang characters at left margin. This is a Heirloom extension and currently ignored. .SS "\&linetabs" Enable or disable line-tabs mode. This is a groff extension and currently unsupported. .SS "\&ll" Change the output line length. Its syntax is as follows: .PP .RS 6n \&.\fB\&ll\fR [[+|-]\fIwidth\fR] .RE .PP If the \fIwidth\fR argument is omitted, the line length is reset to its previous value. The default setting for terminal output is 78n. If a sign is given, the line length is added to or subtracted from; otherwise, it is set to the provided value. Using this request in new manuals is discouraged for several reasons, among others because it overrides the mandoc(1) \fB\-O\fR \fBwidth\fR command line option. .SS "\&lnr" Set local number register. This is a Heirloom extension and currently unsupported. .SS "\&lnrf" Set local floating-point register. This is a Heirloom extension and currently unsupported. .SS "\&lpfx" Set a line prefix. This is a Heirloom extension and currently unsupported. .SS "\&ls" Set line spacing. It takes one integer argument specifying the vertical distance of subsequent output text lines measured in v units. Currently ignored. .SS "\&lsm" Set a leading spaces trap. This is a groff extension and currently unsupported. .SS "\<" Set title line length. Currently ignored. .SS "\&mc" Print margin character in the right margin. Currently ignored. .SS "\&mediasize" Set the device media size. This is a Heirloom extension and currently ignored. .SS "\&minss" Set minimum word space. This is a Heirloom extension and currently ignored. .SS "\&mk" Mark vertical position. Currently ignored. .SS "\&mso" Load a macro file. Ignored because insecure. .SS "\&na" Disable adjusting without changing the adjustment mode. Currently ignored. .SS "\&ne" Declare the need for the specified minimum vertical space before the next trap or the bottom of the page. Currently ignored. .SS "\&nf" Switch to no-fill mode. See man(7). Ignored by mdoc(7). .SS "\&nh" Turn off automatic hyphenation mode. Currently ignored. .SS "\&nhychar" Define hyphenation-inhibiting characters. This is a Heirloom extension and currently ignored. .SS "\&nm" Print line numbers. Currently unsupported. .SS "\&nn" Temporarily turn off line numbering. Currently unsupported. .SS "\&nop" Execute the rest of the input line as a request or macro line. Currently unsupported. .SS "\&nr" Define or change a register. A register is an arbitrary string value that defines some sort of state, which influences parsing and/or formatting. Its syntax is as follows: .PP .RS 6n \.\fB\&nr\fR \fIname\fR [+|-]\fIexpression\fR .RE .PP For the syntax of \fIexpression\fR, see \fINumerical expressions\fR below. If it is prefixed by a sign, the register will be incremented or decremented instead of assigned to. .PP The following register \fIname\fR is handled specially: .TP 8n \fBnS\fR If set to a positive integer value, certain mdoc(7) macros will behave in the same way as in the \fISYNOPSIS\fR section. If set to 0, these macros will behave in the same way as outside the \fISYNOPSIS\fR section, even when called within the \fISYNOPSIS\fR section itself. Note that starting a new mdoc(7) section with the \fB\&Sh\fR macro will reset this register. .SS "\&nrf" Define or change a floating-point register. This is a Heirloom extension and currently unsupported. .SS "\&nroff" Force nroff mode. This is a groff extension and currently ignored. .SS "\&ns" Turn on no-space mode. Currently ignored. .SS "\&nx" Abort processing of the current input file and process another one. Ignored because insecure. .SS "\&open" Open a file for writing. Ignored because insecure. .SS "\&opena" Open a file for appending. Ignored because insecure. .SS "\&os" Output saved vertical space. Currently ignored. .SS "\&output" Output directly to intermediate output. Not supported. .SS "\&padj" Globally control paragraph-at-once adjustment. This is a Heirloom extension and currently ignored. .SS "\&papersize" Set the paper size. This is a Heirloom extension and currently ignored. .SS "\&pc" Change the page number character. Currently ignored. .SS "\&pev" Print environments. This is a groff extension and currently ignored. .SS "\&pi" Pipe output to a shell command. Ignored because insecure. .SS "\&PI" Low-level request used by \fI\&BP\fR. This is a Heirloom extension and currently unsupported. .SS "\&pl" Change page length. Takes one height argument. Currently ignored. .SS "\&pm" Print names and sizes of macros, strings, and diversions. Currently ignored. .SS "\&pn" Change page number of the next page. Currently ignored. .SS "\&pnr" Print all number registers. Currently ignored. .SS "\&po" Set horizontal page offset. Currently ignored. .SS "\&ps" Change point size. Takes one numerical argument. Currently ignored. .SS "\&psbb" Retrieve the bounding box of a PostScript file. Currently unsupported. .SS "\&pshape" Set a special shape for the current paragraph. This is a Heirloom extension and currently unsupported. .SS "\&pso" Include output of a shell command. Ignored because insecure. .SS "\&ptr" Print the names and positions of all traps. This is a groff extension and currently ignored. .SS "\&pvs" Change post-vertical spacing. This is a groff extension and currently ignored. .SS "\&rchar" Remove glyph definitions. Currently unsupported. .SS "\&rd" Read from standard input. Currently ignored. .SS "\&recursionlimit" Set the maximum stack depth for recursive macros. This is a Heirloom extension and currently ignored. .SS "\&return" Exit a macro and return to the caller. Currently unsupported. .SS "\&rfschar" Remove font-specific fallback glyph definitions. Currently unsupported. .SS "\&rhang" Hang characters at right margin. This is a Heirloom extension and currently ignored. .SS "\&rj" Justify unfilled text to the right margin. Currently ignored. .SS "\&rm" Remove a request, macro or string. Its syntax is as follows: .PP .RS 6n \.\fB\&rm\fR \fIname\fR .RE .SS "\&rn" Rename a request, macro, diversion, or string. Currently unsupported. .SS "\&rnn" Rename a number register. Currently unsupported. .SS "\&rr" Remove a register. Its syntax is as follows: .PP .RS 6n \.\fB\&rr\fR \fIname\fR .RE .SS "\&rs" End no-space mode. Currently ignored. .SS "\&rt" Return to marked vertical position. Currently ignored. .SS "\&schar" Define global fallback glyph. This is a groff extension and currently unsupported. .SS "\&sentchar" Define sentence-ending characters. This is a Heirloom extension and currently ignored. .SS "\&shc" Change the soft hyphen character. Currently ignored. .SS "\&shift" Shift macro arguments. Currently unsupported. .SS "\&sizes" Define permissible point sizes. This is a groff extension and currently ignored. .SS "\&so" Include a source file. Its syntax is as follows: .PP .RS 6n \.\fB\&so\fR \fIfile\fR .RE .PP The \fIfile\fR will be read and its contents processed as input in place of the \(oq\&.so\(cq request line. To avoid inadvertent inclusion of unrelated files, mandoc(1) only accepts relative paths not containing the strings "../" and "/..". .PP This request requires man(1) to change to the right directory before calling mandoc(1), per convention to the root of the manual tree. Typical usage looks like: .PP .RS 6n \&.so man3/Xcursor.3 .RE .PP As the whole concept is rather fragile, the use of \fI\&so\fR is discouraged. Use ln(1) instead. .SS "\&spacewidth" Set the space width from the font metrics file. This is a Heirloom extension and currently ignored. .SS "\&special" Define a special font. This is a groff extension and currently ignored. .SS "\&spreadwarn" Warn about wide spacing between words. Currently ignored. .SS "\&ss" Set space character size. Currently ignored. .SS "\&sty" Associate style with a font position. This is a groff extension and currently ignored. .SS "\&substring" Replace a user-defined string with a substring. Currently unsupported. .SS "\&sv" Save vertical space. Currently ignored. .SS "\&sy" Execute shell command. Ignored because insecure. .SS "\&T&" Re-start a table layout, retaining the options of the prior table invocation. See \fI\&TS\fR. .SS "\&ta" Set tab stops. Takes an arbitrary number of arguments. Currently unsupported. .SS "\&tc" Change tab repetition character. Currently unsupported. .SS "\&TE" End a table context. See \fI\&TS\fR. .SS "\&ti" Temporary indent. Currently unsupported. .SS "\&tkf" Enable track kerning for a font. Currently ignored. .SS "\&tl" Print a title line. Currently unsupported. .SS "\&tm" Print to standard error output. Currently ignored. .SS "\&tm1" Print to standard error output, allowing leading blanks. This is a groff extension and currently ignored. .SS "\&tmc" Print to standard error output without a trailing newline. This is a groff extension and currently ignored. .SS "\&tr" Output character translation. Its syntax is as follows: .PP .RS 6n \.\fB\&tr\fR \fI[ab]+\fR .RE .PP Pairs of \fIab\fR characters are replaced (\fIa\fR for \fIb\fR). Replacement (or origin) characters may also be character escapes; thus, .PP .RS 6n tr \e(xx\e(yy .RE .PP replaces all invocations of \e(xx with \e(yy. .SS "\&track" Static letter space tracking. This is a Heirloom extension and currently ignored. .SS "\&transchar" Define transparent characters for sentence-ending. This is a Heirloom extension and currently ignored. .SS "\&trf" Output the contents of a file, disallowing invalid characters. This is a groff extension and ignored because insecure. .SS "\&trimat" Set the TrimBox page parameter for PDF generation. This is a Heirloom extension and currently ignored. .SS "\&trin" Output character translation, ignored by \fB\&asciify\fR. Currently unsupported. .SS "\&trnt" Output character translation, ignored by \e!. Currently unsupported. .SS "\&troff" Force troff mode. This is a groff extension and currently ignored. .SS "\&TS" Begin a table, which formats input in aligned rows and columns. See tbl(7) for a description of the tbl language. .SS "\&uf" Globally set the underline font. Currently ignored. .SS "\&ul" Underline. Currently ignored. .SS "\&unformat" Unformat spaces and tabs in a diversion. Currently unsupported. .SS "\&unwatch" Disable notification for string or macro. This is a Heirloom extension and currently ignored. .SS "\&unwatchn" Disable notification for register. This is a Heirloom extension and currently ignored. .SS "\&vpt" Enable or disable vertical position traps. This is a groff extension and currently ignored. .SS "\&vs" Change vertical spacing. Currently ignored. .SS "\&warn" Set warning level. Currently ignored. .SS "\&warnscale" Set the scaling indicator used in warnings. This is a groff extension and currently ignored. .SS "\&watch" Notify on change of string or macro. This is a Heirloom extension and currently ignored. .SS "\&watchlength" On change, report the contents of macros and strings up to the specified length. This is a Heirloom extension and currently ignored. .SS "\&watchn" Notify on change of register. This is a Heirloom extension and currently ignored. .SS "\&wh" Set a page location trap. Currently unsupported. .SS "\&while" Repeated execution while a condition is true. Currently unsupported. .SS "\&write" Write to an open file. Ignored because insecure. .SS "\&writec" Write to an open file without appending a newline. Ignored because insecure. .SS "\&writem" Write macro or string to an open file. Ignored because insecure. .SS "\&xflag" Set the extension level. This is a Heirloom extension and currently ignored. .SS "Numerical expressions" The \fI\&nr\fR, \fI\&if\fR, and \fI\&ie\fR requests accept integer numerical expressions as arguments. These are always evaluated using the C \fIint\fR type; integer overflow works the same way as in the C language. Numbers consist of an arbitrary number of digits \(oq0\(cq to \(oq9\(cq prefixed by an optional sign \(oq+\(cq or \(oq-\(cq. Each number may be followed by one optional scaling unit described below \fIScaling Widths\fR. The following equations hold: .nf .sp .RS 6n 1i = 6v = 6P = 10m = 10n = 72p = 1000M = 240u = 240 254c = 100i = 24000u = 24000 1f = 65536u = 65536 .RE .fi .PP The following binary operators are implemented. Unless otherwise stated, they behave as in the C language: .TP 4n \fB+\fR addition .PD 0 .TP 4n \fB-\fR subtraction .TP 4n \fB*\fR multiplication .TP 4n \fB/\fR division .TP 4n \fB%\fR remainder of division .TP 4n \fB<\fR less than .TP 4n \fB>\fR greater than .TP 4n \fB==\fR equal to .TP 4n \fB=\fR equal to, same effect as \fB==\fR (this differs from C) .TP 4n \fB<=\fR less than or equal to .TP 4n \fB>=\fR greater than or equal to .TP 4n \fB<>\fR not equal to (corresponds to C \fB!=\fR; this one is of limited portability, it is supported by Heirloom roff, but not by groff) .TP 4n \fB&\fR logical and (corresponds to C \fB&&\fR) .TP 4n \fB\&:\fR .br logical or (corresponds to C \fB\&||\fR) .TP 4n \fB?\fR maximum (not available in C) .PD .PP There is no concept of precedence; evaluation proceeds from left to right, except when subexpressions are enclosed in parantheses. Inside parentheses, whitespace is ignored. .SH "ESCAPE SEQUENCE REFERENCE" The mandoc(1) \fBroff\fR parser recognises the following escape sequences. Note that the \fBroff\fR language defines more escape sequences not implemented in mandoc(1). In mdoc(7) and man(7) documents, using escape sequences is discouraged except for those described in the \fILANGUAGE SYNTAX\fR section above. .PP A backslash followed by any character not listed here simply prints that character itself. .SS "\e" A backslash at the end of an input line can be used to continue the logical input line on the next physical input line, joining the text on both lines together as if it were on a single input line. .SS "\e" The escape sequence backslash-space (\(oq\e\ \&\(cq) is an unpaddable space-sized non-breaking space character; see \fIWhitespace\fR. .SS "\e\(dq" The rest of the input line is treated as \fIComments\fR. .SS "\e%" Hyphenation allowed at this point of the word; ignored by mandoc(1). .SS "\e&" Non-printing zero-width character; see \fIWhitespace\fR. .SS "\e\(aq" Acute accent special character; use \(oq\e(aa\(cq instead. .SS "\e(\fIcc\fR" \fISpecial Characters\fR with two-letter names, see mandoc_char(7). .SS "\e*[\fIname\fR]" Interpolate the string with the \fIname\fR; see \fIPredefined Strings\fR and \fIds\fR. For short names, there are variants \e*\fIc\fR and \e*(\fIcc\fR. .SS "\e," Left italic correction (groff extension); ignored by mandoc(1). .SS "\e-" Special character \(Lqmathematical minus sign\(Rq. .SS "\e/" Right italic correction (groff extension); ignored by mandoc(1). .SS "\e[\fIname\fR]" \fISpecial Characters\fR with names of arbitrary length, see mandoc_char(7). .SS "\e^" One-twelfth em half-narrow space character, effectively zero-width in mandoc(1). .SS "\e`" Grave accent special character; use \(oq\e(ga\(cq instead. .SS "\e{" Begin conditional input; see \fIif\fR. .SS "\e\(ba" One-sixth em narrow space character, effectively zero-width in mandoc(1). .SS "\e}" End conditional input; see \fIif\fR. .SS "\e~" Paddable non-breaking space character. .SS "\e0" Digit width space character. .SS "\eA\(aq\fIstring\fR\(aq" Anchor definition; ignored by mandoc(1). .SS "\eB\(aq\fIstring\fR\(aq" Interpolate \(oq1\(cq if \fIstring\fR conforms to the syntax of \fINumerical expressions\fR explained above and \(oq0\(cq otherwise. .SS "\eb\(aq\fIstring\fR\(aq" Bracket building function; ignored by mandoc(1). .SS "\eC\(aq\fIname\fR\(aq" \fISpecial Characters\fR with names of arbitrary length. .SS "\ec" When encountered at the end of an input text line, the next input text line is considered to continue that line, even if there are request or macro lines in between. No whitespace is inserted. .SS "\eD\(aq\fIstring\fR\(aq" Draw graphics function; ignored by mandoc(1). .SS "\ed" Move down by half a line; ignored by mandoc(1). .SS "\ee" Backslash special character. .SS "\eF[\fIname\fR]" Switch font family (groff extension); ignored by mandoc(1). For short names, there are variants \eF\fIc\fR and \eF(\fIcc\fR. .SS "\ef[\fIname\fR]" Switch to the font \fIname\fR, see \fIText Decoration\fR. For short names, there are variants \ef\fIc\fR and \ef(\fIcc\fR. .SS "\eg[\fIname\fR]" Interpolate the format of a number register; ignored by mandoc(1). For short names, there are variants \eg\fIc\fR and \eg(\fIcc\fR. .SS "\eH\(aq[+|-]\fInumber\fR\(aq" Set the height of the current font; ignored by mandoc(1). .SS "\eh\(aq\fInumber\fR\(aq" Horizontal motion; ignored by mandoc(1). .SS "\ek[\fIname\fR]" Mark horizontal input place in register; ignored by mandoc(1). For short names, there are variants \ek\fIc\fR and \ek(\fIcc\fR. .SS "\eL\(aq\fInumber\fR[\fIc\fR]\(aq" Vertical line drawing function; ignored by mandoc(1). .SS "\el\(aq\fInumber\fR[\fIc\fR]\(aq" Horizontal line drawing function; ignored by mandoc(1). .SS "\eM[\fIname\fR]" Set fill (background) color (groff extension); ignored by mandoc(1). For short names, there are variants \eM\fIc\fR and \eM(\fIcc\fR. .SS "\em[\fIname\fR]" Set glyph drawing color (groff extension); ignored by mandoc(1). For short names, there are variants \em\fIc\fR and \em(\fIcc\fR. .SS "\eN\(aq\fInumber\fR\(aq" Character \fInumber\fR on the current font. .SS "\en[\fIname\fR]" Interpolate the number register \fIname\fR. For short names, there are variants \en\fIc\fR and \en(\fIcc\fR. .SS "\eo\(aq\fIstring\fR\(aq" Overstrike, writing all the characters contained in the \fIstring\fR to the same output position. In terminal and HTML output modes, only the last one of the characters is visible. .SS "\eR\(aq\fIname\fR [+|-]\fInumber\fR\(aq" Set number register; ignored by mandoc(1). .SS "\eS\(aq\fInumber\fR\(aq" Slant output; ignored by mandoc(1). .SS "\es\(aq[+|-]\fInumber\fR\(aq" Change point size; ignored by mandoc(1). Alternative forms \es[+|-]\fIn\fR, \es[+|-]\(aq\fInumber\fR\(aq, \es[[+|-]\fInumber\fR], and \es[+|-][\fInumber\fR] are also parsed and ignored. .SS "\et" Horizontal tab; ignored by mandoc(1). .SS "\eu" Move up by half a line; ignored by mandoc(1). .SS "\eV[\fIname\fR]" Interpolate an environment variable; ignored by mandoc(1). For short names, there are variants \eV\fIc\fR and \eV(\fIcc\fR. .SS "\ev\(aq\fInumber\fR\(aq" Vertical motion; ignored by mandoc(1). .SS "\ew\(aq\fIstring\fR\(aq" Interpolate the width of the \fIstring\fR. The mandoc(1) implementation assumes that after expansion of user-defined strings, the \fIstring\fR only contains normal characters, no escape sequences, and that each character has a width of 24 basic units. .SS "\eX\(aq\fIstring\fR\(aq" Output \fIstring\fR as device control function; ignored in nroff mode and by mandoc(1). .SS "\ex\(aq\fInumber\fR\(aq" Extra line space function; ignored by mandoc(1). .SS "\eY[\fIname\fR]" Output a string as a device control function; ignored in nroff mode and by mandoc(1). For short names, there are variants \eY\fIc\fR and \eY(\fIcc\fR. .SS "\eZ\(aq\fIstring\fR\(aq" Print \fIstring\fR with zero width and height; ignored by mandoc(1). .SS "\ez" Output the next character without advancing the cursor position. .SH "COMPATIBILITY" The mandoc(1) implementation of the \fBroff\fR language is intentionally incomplete. Unimplemented features include: .TP 4n \fB-\fR For security reasons, mandoc(1) never reads or writes external files except via \fI\&so\fR requests with safe relative paths. .PD 0 .TP 4n \fB-\fR There is no automatic hyphenation, no adjustment to the right margin, and no centering; the output is always set flush-left. .TP 4n \fB-\fR Support for setting tabulator positions and tabulator and leader characters is missing, and support for manually changing indentation is limited. .TP 4n \fB-\fR The \(oqu\(cq scaling unit is the default terminal unit. In traditional troff systems, this unit changes depending on the output media. .TP 4n \fB-\fR Width measurements are implemented in a crude way and often yield wrong results. Explicit movement requests and escapes are ignored. .TP 4n \fB-\fR There is no concept of output pages, no support for floats, graphics drawing, and picture inclusion; terminal output is always continuous. .TP 4n \fB-\fR Requests regarding color, font families, and glyph manipulation are ignored. Font support is very limited. Kerning is not implemented, and no ligatures are produced. .TP 4n \fB-\fR The "\(aq" macro control character does not suppress output line breaks. .TP 4n \fB-\fR Diversions are not implemented, and support for traps is very incomplete. .TP 4n \fB-\fR While recursion is supported, \fI\&while\fR loops are not. .PD .PP The special semantics of the \fBnS\fR number register is an idiosyncracy of OpenBSD manuals and not supported by other mdoc(7) implementations. .SH "SEE ALSO" mandoc(1), eqn(7), man(7), mandoc_char(7), mdoc(7), tbl(7) .PP Joseph F. Ossanna, Brian W. Kernighan, \fITroff User's Manual\fR, \fIAT&T Bell Laboratories\fR, Computing Science Technical Report, 54, http://www.kohala.com/start/troff/cstr54.ps, Murray Hill, New Jersey, 1976 and 1992. .PP Joseph F. Ossanna, Brian W. Kernighan, and Gunnar Ritter, \fIHeirloom Documentation Tools Nroff/Troff User's Manual\fR, http://heirloom.sourceforge.net/doctools/troff.pdf, September 17, 2007. .SH "HISTORY" The RUNOFF typesetting system, whose input forms the basis for \fBroff\fR, was written in MAD and FAP for the CTSS operating system by Jerome E. Saltzer in 1964. Doug McIlroy rewrote it in BCPL in 1969, renaming it \fBroff\fR. Dennis M. Ritchie rewrote McIlroy's \fBroff\fR in PDP-11 assembly for Version\~1 AT&T UNIX, Joseph F. Ossanna improved roff and renamed it nroff for Version\~2 AT&T UNIX, then ported nroff to C as troff, which Brian W. Kernighan released with Version\~7 AT&T UNIX. In 1989, James Clarke re-implemented troff in C++, naming it groff. .SH "AUTHORS" This \fBroff\fR reference was written by Kristaps Dzonsons <\fIkristaps@bsd.lv\fR> and Ingo Schwarze <\fIschwarze@openbsd.org\fR>.