|MAN.CONF(5)||File Formats Manual||MAN.CONF(5)|
man.conf - configuration file for man
This is the configuration file for the man(1), apropos(1), and makewhatis(8) utilities. Its presence, and all directives, are optional.
This file is an ASCII text file. Leading whitespace on lines, lines starting with ‘#’, and blank lines are ignored. Words are separated by whitespace. The first word on each line is the name of a configuration directive.
The following directives are supported:
- manpath path
- Override the default search path for man(1), apropos(1), and
makewhatis(8). It can be used multiple times to specify multiple paths,
with the order determining the manual page search order.
Each path is a tree containing subdirectories whose names consist of the strings ‘man’ and/or ‘cat’ followed by the names of sections, usually single digits. The former are supposed to contain unformatted manual pages in mdoc(7) and/or man(7) format; file names should end with the name of the section preceded by a dot. The latter should contain preformatted manual pages; file names should end with ‘.0’.
Creating a mandoc.db(5) database with makewhatis(8) in each directory configured with manpath is recommended and necessary for apropos(1) to work, but not strictly required for man(1).
- output option [value]
- Configure the default value of an output option. These directives are
overridden by the -O command line options of the same names. For
details, see the mandoc(1) manual.
0 option value used by -T fragment none html includes string html indent integer ascii, utf8 man string html paper string ps, pdf style string html width integer ascii, utf8
- _whatdb path/whatis.db
- This directive provides the same functionality as manpath, but using a historic and misleading syntax. It is kept for backward compatibility for now, but will eventually be removed.
The following configuration file reproduces the defaults: installing it is equivalent to not having a man.conf file at all.
manpath /usr/share/man manpath /usr/X11R6/man manpath /usr/local/man
apropos(1), man(1), makewhatis(8)
A relatively complicated man.conf file format first appeared in 4.3BSD-Reno. For OpenBSD 5.8, it was redesigned from scratch, aiming for simplicity.
Ingo Schwarze <email@example.com>
|December 28, 2016||Debian|