|NTPD(8)||System Manager's Manual||NTPD(8)|
ntpddaemon synchronizes the local clock to one or more remote NTP servers or local timedelta sensors.
ntpdcan also act as an NTP server itself, redistributing the local time. It implements the Simple Network Time Protocol version 4, as described in RFC 5905, and the Network Time Protocol version 3, as described in RFC 1305. Time can also be fetched from TLS HTTPS servers to reduce the impact of unauthenticated NTP man-in-the-middle attacks, but support is currently
not enabled on Debiandue to missing LibreSSL's libtls implementation at this time.
The options are as follows:
- Do not daemonize. If this option is specified,
ntpdwill run in the foreground and log to stderr.
- Use file as the configuration file, instead of the default /etc/openntpd/ntpd.conf.
- Configtest mode. Only check the configuration file for validity.
- Write pid to file
- Do not set the time immediately at startup. This is the default.
- Try to set the time immediately at startup, as opposed to slowly adjusting
ntpdwill stay in the foreground for up to 15 seconds waiting for one of the configured NTP servers to reply.
- This option allows
ntpdto send DEBUG priority messages to syslog.
ntpd uses the adjtime(2)
system call to correct the local system time without causing time jumps.
Adjustments of 32ms and greater are logged using
syslog(3). The threshold value is chosen to avoid having
local clock drift thrash the log files. Should
be started with the
option, all calls to adjtime(2) will be logged.
After the local clock is synchronized,
ntpd adjusts the clock frequency using the
adjfreq(2) system call to compensate for systematic
ntpd starts up, it reads settings
from its configuration file, typically ntpd.conf(5), and
its initial clock drift from
/var/lib/openntpd/ntpd.drift. Clock drift is
periodically written to the drift file thereafter.
- Default configuration file.
- Drift file.
- Socket file for communication with ntpctl(8).
SEE ALSO¶date(1), adjfreq(2), adjtime(2), ntpd.conf(5), ntpctl(8),
STANDARDS¶David L. Mills, Network Time Protocol (Version 3): Specification, Implementation and Analysis, RFC 1305, March 1992.
David L. Mills, Jim Martin, Jack Burbank, and William Kasch, Network Time Protocol Version 4: Protocol and Algorithms Specification, RFC 5905, June 2010.
ntpdprogram first appeared in OpenBSD 3.6.
|September 6, 2017||Linux 4.19.0-10-amd64|