|NEWFS_HFS(8)||System Manager's Manual||NEWFS_HFS(8)|
mkfs.hfsbuilds an HFS Plus file system on the specified special device.
The file system default parameters are calculated based on the
size of the disk partition. Typically the defaults are reasonable, however
mkfs.hfs has several options to allow the defaults
to be selectively overridden. The options are as follows:
- Causes the file system parameters to be printed out without really creating the file system.
- Set the owner of the file system's root directory to uid.
- Set the group of the file system's root directory to gid.
- Specify the access permissions mask for the file system's root directory.
- Creates a legacy HFS format filesystem. This option is not recommended for file systems that will be primarily used with Mac OS X or Darwin.
- Creates a case-sensitive HFS Plus filesystem. By default a case-insensitive filesystem is created. Case-sensitive HFS Plus file systems require a Mac OS X version of 10.3 (Darwin 7.0) or later.
- Adds an HFS wrapper around the HFS Plus file system. This wrapper is required if the file system will be used to boot natively into Mac OS 9.
- The allocation block size of the file system. The default value is 4096.
- This specifies the clump and/or
initial sizes, in allocation blocks, for the various
metadata files. Clump sizes are specified with the
-coption followed by a comma separated list of the form arg=blocks.
Example: -c c=5000,e=500
- Set the attribute file clump size.
- Set the allocation bitmap file clump size.
- Set the catalog file clump size.
- Set the extent overflow file clump size.
- This specifies the initial catalog node ID for user files and directories. The default value is 16.
- Creates a journaled HFS+ volume. The default journal size is 8MB. Appending an 'M' to the journal size implies megabytes (i.e. 64M is 64 megabytes). The maximum journal size is 512 megabytes.
- This specifies the b-tree node sizes, in bytes, for the
various b-tree files. Node sizes are specified with the
-noption followed by a comma separated list of the form arg=bytes. The node size must be a power of two and no larger than 32768 bytes.
Example: -n c=8192,e=4096
- Set the attribute b-tree node size.
- Set the catalog b-tree node size.
- Set the extent overflow b-tree node size.
- Volume name (file system name) in ascii or UTF-8 format.
mkfs.hfscommand appeared in Mac OS X Server 1.0 .
|April 1, 2003||Mac OS X|