|LINUX(4)||Device Drivers Manual||LINUX(4)|
linux — Linux ABI
To compile support for this ABI into an i386 kernel place the following line in your kernel configuration file:
for an amd64 kernel use:
Alternatively, to load the ABI as a module at boot time, place the following line in loader.conf(5):
linux module provides limited Linux
ABI (application binary interface) compatibility, making it possible to run
many unmodified Linux applications and libraries without the need for
virtualization or emulation. Some of the facilities provided are:
- An image activator for correctly branded elf(5) executable images
- Special signal handling for activated images
- Linux to native system call translation
- Linux-specific system calls
Note that dynamically linked Linux executables will require a suitable environment in /compat/linux. This includes native Linux shared libraries, and Linux-specific virtual filesystems. To set it up, install the emulators/linux_base-c7 port or the linux_base-c7 package, and add the following line to the rc.conf(5) file:
To avoid mounting Linux-specific filesystems at startup, also add the following line:
- Enable debugging messages. Set to 0 to silence them. Defaults to 1.
- Default soft openfiles resource limit for Linux applications. Set to -1 to disable the limit. Defaults to 1024.
- Path to the Linux run-time environment. Defaults to /compat/linux.
- Linux kernel operating system name.
- Linux kernel operating system release. Changing this to something else is discouraged on non-development systems, because it may change the way Linux programs work. Recent versions of GNU libc are known to use different syscalls depending on the value of this sysctl.
- Linux Open Sound System version.
- When set to 1, it prevents Linux applications from resetting the termios(4) VSTATUS setting. From a user perspective, this makes SIGINFO work for Linux executables. Defaults to 0.
- minimal Linux run-time environment
- device file system, see devfs(5)
- file descriptor file system mounted with the
linrdlnkoption, see fdescfs(5)
- in-memory file system, see tmpfs(5)
- Linux process file system, see linprocfs(5)
- Linux kernel objects file system, see linsysfs(5)
Linux ABI support first appeared in FreeBSD 2.1.
Support for some of the Linux-specific system calls and system call arguments is missing.
|July 5, 2020||Debian|