|ACPI(4)||Device Drivers Manual||ACPI(4)|
acpi — Advanced
Configuration and Power Management support
acpi driver provides support for the
Intel/Microsoft/Compaq/Toshiba ACPI standard. This support includes platform
hardware discovery (superseding the PnP and PCI BIOS), as well as power
management (superseding APM) and other features. ACPI core support is
provided by the ACPI CA reference implementation from Intel.
Note that the
acpi driver is automatically
loaded by the loader(8), and should only be compiled into
the kernel on platforms where ACPI is mandatory.
acpi driver is intended to provide
power management without user intervention. If the default settings are not
optimal, the following sysctls can be used to modify or monitor
acpi behavior. Note that some variables will be
available only if the given hardware supports them (such as
- Enable dumping Debug objects without
options ACPI_DEBUG. Default is 0, ignore Debug objects.
- Debugging information listing the percent of total usage for each sleep state. The values are reset when dev.cpu.N.cx_lowest is modified.
- Lowest Cx state to use for idling the CPU. A scheduling algorithm will
select states between
C1and this setting as system load dictates. To enable ACPI CPU idling control, machdep.idle should be set to
acpiif it is listed in machdep.idle_available.
- List of supported CPU idle states and their transition latency in
microseconds. Each state has a type (e.g.,
C1is equivalent to the ia32
C2provides a deeper sleep with the same semantics, and
C3provides the deepest sleep but additionally requires bus mastering to be disabled. States greater than
C3provide even more power savings with the same semantics as the
C3state. Deeper sleeps provide more power savings but increased transition latency when an interrupt occurs.
- List of supported CPU idle states and their transition methods, as directed by the firmware.
- AC line state (1 means online, 0 means on battery power).
- Disable ACPI during the reboot process. Most systems reboot fine with ACPI still enabled, but some require exiting to legacy mode first. Default is 0, leave ACPI enabled.
- Use the ACPI Reset Register capability to reboot the system. Some newer systems require use of this register, while some only work with legacy rebooting support.
- Suspend state
S5) to enter when the lid switch (i.e., a notebook screen) is closed. Default is “
NONE” (do nothing).
- Suspend state
S5) to enter when the power button is pressed. Default is
- Reset the video adapter from real mode during the resume path. Some systems need this help, others have display problems if it is enabled. Default is 0 (disabled).
- Indicate whether the system supports
S4BIOS. This means that the BIOS can handle all the functions of suspending the system to disk. Otherwise, the OS is responsible for suspending to disk (
S4OS). Most current systems do not support
- Suspend state
S5) to enter when the sleep button is pressed. This is usually a special function button on the keyboard. Default is
- Wait this number of seconds between preparing the system to suspend and actually entering the suspend state. Default is 1 second.
- Suspend states
S5) supported by the BIOS.
- Quick suspend to RAM. The CPU enters a lower power state, but most peripherals are left running.
- Lower power state than
S1, but with the same basic characteristics. Not supported by many systems.
- Suspend to RAM. Most devices are powered off, and the system stops running except for memory refresh.
- Suspend to disk. All devices are powered off, and the system stops
running. When resuming, the system starts as if from a cold power on.
Not yet supported by FreeBSD unless
- System shuts down cleanly and powers off.
- Enable verbose printing from the various ACPI subsystems.
- Enables loading of a custom ACPI DSDT.
- Name of the DSDT table to load, if loading is enabled.
- Do not use the MADT to match ACPI Processor objects to CPUs. This is needed on a few systems with a buggy BIOS that does not use consistent processor IDs. Default is 0 (disabled).
- Selectively disables portions of ACPI for debugging purposes.
- Enable less strict ACPI implementations. Default is 1, ignore common BIOS mistakes.
- Specify the number of task threads that are started on boot. Limiting this to 1 may help work around various BIOSes that cannot handle parallel requests. The default value is 3.
- Override any automatic quirks completely.
- Beep the PC speaker on resume. This can help diagnose suspend/resume problems. Default is 0 (disabled).
- Set this to 1 to disable all of ACPI. If ACPI has been disabled on your system due to a blacklist entry for your BIOS, you can set this to 0 to re-enable ACPI for testing.
- Delay in milliseconds to wait for the EC to respond. Try increasing this
number if you get the error
- Override the assumed memory starting address for PCI host bridges.
- hw.acpi.install_interface, hw.acpi.remove_interface
- Install or remove OS interface(s) to control return value of
_OSI’ query method. When an OS interface is specified in hw.acpi.install_interface,
_OSIquery for the interface returns it is supported. Conversely, when an OS interface is specified in hw.acpi.remove_interface,
_OSIquery returns it is not supported. Multiple interfaces can be specified in a comma-separated list and any leading white spaces will be ignored. For example, "
FreeBSD, Linux" is a valid list of two interfaces "
FreeBSD" and "
- Enables calling the VESA reset BIOS vector on the resume path. This can fix some graphics cards that have problems such as LCD white-out after resume. Default is 0 (disabled).
- Allow override of whether methods execute in parallel or not. Enable this
for serial behavior, which fixes
AE_ALREADY_EXISTS" errors for AML that really cannot handle parallel method execution. It is off by default since this breaks recursive methods and some IBMs use such code.
- Turn on verbose debugging information about what ACPI is doing.
- Override the interrupt to use for this link and index. This capability
should be used carefully, and only if a device is not working with
acpienabled. "%s" is the name of the link (e.g., LNKA). "%d" is the resource index when the link supports multiple IRQs. Most PCI links only have one IRQ resource, so the below form should be used.
- Override the interrupt to use. This capability should be used carefully,
and only if a device is not working with
acpienabled. "%s" is the name of the link (e.g., LNKA).
Since ACPI support on different platforms varies greatly, there are many debugging and tuning options available.
For machines known not to work with
enabled, there is a BIOS blacklist. Currently, the blacklist only controls
acpi should be disabled or not. In the
future, it will have more granularity to control features (the
infrastructure for that is already there).
acpi (for debugging purposes,
etc.) on machines that are on the blacklist, set the kernel environment
variable hint.acpi.0.disabled to 0. Before trying
this, consider updating your BIOS to a more recent version that may be
compatible with ACPI.
To disable the
acpi driver completely, set
the kernel environment variable hint.acpi.0.disabled
Some i386 machines totally fail to operate with some or all of ACPI disabled. Other i386 machines fail with ACPI enabled. Disabling all or part of ACPI on non-i386 platforms (i.e., platforms where ACPI support is mandatory) may result in a non-functional system.
acpi driver comprises a set of
drivers, which may be selectively disabled in case of problems. To disable a
sub-driver, list it in the kernel environment variable
debug.acpi.disabled. Multiple entries can be listed,
separated by a space.
ACPI sub-devices and features that can be disabled:
- Disable all ACPI features and devices.
- (device) Supports AC adapter.
- (feature) Probes and attaches subdevices. Disabling will avoid scanning the ACPI namespace entirely.
- (feature) Attaches standard ACPI sub-drivers and
devices enumerated in the ACPI namespace. Disabling this has a similar
effect to disabling “
bus”, except that the ACPI namespace will still be scanned.
- (device) Supports ACPI button devices (typically power and sleep buttons).
- (device) Control-method batteries device.
- (device) Supports CPU power-saving and speed-setting functions.
- (device) Supports the ACPI Embedded Controller interface, used to communicate with embedded platform controllers.
- (device) Supports an ISA bus bridge defined in the ACPI namespace, typically as a child of a PCI bus.
- (device) Supports an ACPI laptop lid switch, which typically puts a system to sleep.
- (feature) Do not ask firmware for available
x86-vendor specific methods to enter
Cxsleep states. Only query and use the generic I/O-based entrance method. The knob is provided to work around inconsistencies in the tables filled by firmware.
- (feature) Do not honor quirks. Quirks automatically disable ACPI functionality based on the XSDT table's OEM vendor name and revision date.
- (device) Supports Host to PCI bridges.
- (feature) Performs PCI interrupt routing.
- (device) Pseudo-devices containing resources which ACPI claims.
- (device) Supports system cooling and heat management.
- (device) Implements a timecounter using the ACPI fixed-frequency timer.
- (device) Supports acpi_video(4) which may conflict with agp(4) device.
It is also possible to avoid portions of the ACPI namespace which may be causing problems, by listing the full path of the root of the region to be avoided in the kernel environment variable debug.acpi.avoid. The object and all of its children will be ignored during the bus/children scan of the namespace. The ACPI CA code will still know about the avoided region.
To enable debugging output,
acpi must be
options ACPI_DEBUG. Debugging output
is separated between layers and levels, where a layer is a component of the
ACPI subsystem, and a level is a particular kind of debugging output.
Both layers and levels are specified as a whitespace-separated list of tokens, with layers listed in debug.acpi.layer and levels in debug.acpi.level.
The first set of layers is for ACPI-CA components, and the second is for FreeBSD drivers. The ACPI-CA layer descriptions include the prefix for the files they refer to. The supported layers are:
- Utility ("ut") functions
- Hardware access ("hw")
- Event and GPE ("ev")
- Table access ("tb")
- Namespace evaluation ("ns")
- AML parser ("ps")
- Internal representation of interpreter state ("ds")
- Execute AML methods ("ex")
- Resource parsing ("rs")
- Debugger implementation ("db", "dm")
- Usermode support routines ("os")
- Disassembler implementation (unused)
- All the above ACPI-CA components
- AC adapter driver
- Control-method battery driver
- ACPI, ISA, and PCI bus drivers
- Power and sleep button driver
- Embedded controller driver
- Fan driver
- Platform-specific driver for hotkeys, LED, etc.
- Power resource driver
- CPU driver
- Thermal zone driver
- Timer driver
- All the above FreeBSD ACPI drivers
The supported levels are:
- Initialization progress
- Stores to objects
- General information and progress
- Repair a common problem with predefined methods
- All the previous levels
- All the previous levels
- All the previous levels
- Synonym for "
- All the previous levels
- All levels after
Selection of the appropriate layer and level values is important
to avoid massive amounts of debugging output. For example, the following
configuration is a good way to gather initial information. It enables debug
output for both ACPI-CA and the
printing basic information about errors, warnings, and progress.
debug.acpi.layer="ACPI_ALL_COMPONENTS ACPI_ALL_DRIVERS" debug.acpi.level="ACPI_LV_ALL_EXCEPTIONS"
Debugging output by the ACPI CA subsystem is prefixed with the module name in lowercase, followed by a source line number. Output from the FreeBSD-local code follows the same format, but the module name is uppercased.
OVERRIDING YOUR BIOS BYTECODE¶
ACPI interprets bytecode named AML (ACPI Machine Language) provided by the BIOS vendor as a memory image at boot time. Sometimes, the AML code contains a bug that does not appear when parsed by the Microsoft implementation. FreeBSD provides a way to override it with your own AML code to work around or debug such problems. Note that all AML in your DSDT and any SSDT tables is overridden.
In order to load your AML code, you must edit /boot/loader.conf and include the following lines.
acpi_dsdt_load="YES" acpi_dsdt_name="/boot/acpi_dsdt.aml" # You may change this name.
ACPI is only found and supported on i386/ia32 and amd64.
Compaq Computer Corporation, Intel Corporation, Microsoft Corporation, Phoenix Technologies Ltd., and Toshiba Corporation, Advanced Configuration and Power Interface Specification, http://acpi.info/spec.htm, August 25, 2003.
The ACPI CA subsystem is developed and maintained by Intel Architecture Labs.
The following people made notable contributions to the ACPI subsystem in FreeBSD: Michael Smith, Takanori Watanabe <takawata@jp.FreeBSD.org>, Mitsuru IWASAKI <iwasaki@jp.FreeBSD.org>, Munehiro Matsuda, Nate Lawson, the ACPI-jp mailing list at <acpi-jp@jp.FreeBSD.org>, and many other contributors.
This manual page was written by Michael Smith <msmith@FreeBSD.org>.
Many BIOS versions have serious bugs that may cause system
instability, break suspend/resume, or prevent devices from operating
properly due to IRQ routing problems. Upgrade your BIOS to the latest
version available from the vendor before deciding it is a problem with
|May 9, 2015||Debian|