Scroll to navigation

TPMLIB_ChooseTPMVersion(3) TPMLIB_ChooseTPMVersion(3)

NAME

TPMLIB_ChooseTPMVersion - Choose the version of the TPM

SYNOPSIS

#include <libtpms/tpm_types.h>

#include <libtpms/tpm_library.h>

TPM_RESULT TPMLIB_ChooseTPMVersion(TPMLIB_TPMVersion ver);

 typedef enum TPMLIB_TPMVersion {
    TPMLIB_TPM_VERSION_1_2,
    TPMLIB_TPM_VERSION_2,
 } TPMLIB_TPMVersion;

DESCRIPTION

The TPMLIB_ChooseTPMVersion() function is used to choose the version of the TPM, either a TPM 1.2 or TPM 2.

This function must be called before TPMLIB_MainInit() is called and will otherwise return an error. This function may be called again once TPMLIB_Terminate() has been called.

If this function is not called, the last chosen TPM version will be started with TPMLIB_MainInit(). If this function is not called, a TPM 1.2 will be used.

ERRORS

The version of the TPM was chosen successfully.
The choice of the TPM was wrong, or TPMLIB_MainInit() has already been called.

For a complete list of TPM error codes please consult the include file libtpms/tpm_error.h

SEE ALSO

TPMLIB_MainInit(3), TPMLIB_Terminate(3)

2022-08-14 libtpms